Bug 1575089 - Grub Customizer doesn't start
Summary: Grub Customizer doesn't start
Keywords:
Status: CLOSED DUPLICATE of bug 1570260
Alias: None
Product: Fedora
Classification: Fedora
Component: grub-customizer
Version: 28
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Vasiliy Glazov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 18:01 UTC by daniele356
Modified: 2018-05-04 18:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-04 18:41:29 UTC
Type: Bug


Attachments (Terms of Use)

Description daniele356 2018-05-04 18:01:59 UTC
Description of problem: 
I have 3 kernels installed (one related to Fedora 28 and two related to Fedora 27) and the rescue version of Fedora, but on boot GRUB shows me 8 entries which, 4 of those, are the exact copy of the already listed kernels. I've tried to use Grub Customizer to "recover" from this bug but It doesn't start.

Version-Release number of selected component (if applicable):
5.0.6-7

How reproducible:
Launch "grub-customizer" command on a shell.

Steps to Reproduce:
1. Open terminal emulator.
2. Run grub-customizer.

Actual results:
 *** initializing (w/o specified bootloader type)…
   * reading partition info…
/usr/include/c++/8/bits/basic_string.h:1048: std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::operator[](std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type) [with _CharT = char; _Traits = std::char_traits<char>; _Alloc = std::allocator<char>; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference = char&; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type = long unsigned int]: Assertion '__pos <= size()' failed.

Expected results:
grub-customizer GUI

Additional info:
I've upgraded my workstation via dnf and my laptop has UEFI firmware.
I think that if this issue will be fixed,maybe, It could help me solve the problem related to duplicated entries shown on boot by GRUB.

Comment 1 Vasiliy Glazov 2018-05-04 18:41:29 UTC

*** This bug has been marked as a duplicate of bug 1570260 ***


Note You need to log in before you can comment on or make changes to this bug.