Bug 1570260 - gub customizer will not start after update to latest version
Summary: gub customizer will not start after update to latest version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: grub-customizer
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vasiliy Glazov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1575089 1576031 1576835 1579923 1583132 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-21 11:37 UTC by davis.paul.luther.sr
Modified: 2018-07-03 12:54 UTC (History)
20 users (show)

Fixed In Version: grub-customizer-5.0.8-1.fc27 grub-customizer-5.0.8-1.fc28 grub-customizer-5.0.8-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 16:06:51 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1767051 0 None None None 2018-04-26 07:15:32 UTC

Description davis.paul.luther.sr 2018-04-21 11:37:25 UTC
Description of problem:will not run after updating to latest version


Version-Release number of selected component (if applicable):


How reproducible:try to run iy


Steps to Reproduce:
1.try to run it
2.crashes
3.

Actual results:(grub-customizer:13311): Gtk-WARNING **: 07:35:37.305: Theme parsing error: gtk-widgets.css:161:27: The style property GtkButton:image-spacing is deprecated and shouldn't be used anymore. It will be removed in a future version



Expected results:open grub customizer


Additional info:

Comment 1 Vasiliy Glazov 2018-04-21 18:07:59 UTC
Do you use Gnome with wayland?

Comment 2 g2649588 2018-04-22 11:48:20 UTC
I see the same thing on XFCE with X11, minus the gtk warnings.  It brings up the polkit authorization window but crashes after putting in the password.


$ grub-customizer
 *** initializing (w/o specified bootloader type)…
   * reading partition info…
/usr/include/c++/8/bits/basic_string.h:1048: std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::operator[](std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type) [with _CharT = char; _Traits = std::char_traits<char>; _Alloc = std::allocator<char>; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference = char&; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type = long unsigned int]: Assertion '__pos <= size()' failed.
[martin@SempronWired ~]$

Comment 3 Richard Morehouse 2018-05-02 01:00:16 UTC
i use KDE and see the same error as shown in comment #2 by g2649588@nwytg.com

Comment 4 Netzmeister 2018-05-03 10:21:01 UTC
I have the same Problem. Fedora 28 Workstation (GNOME with Wayland and XORG)

Comment 5 ben 2018-05-03 14:38:28 UTC
Upgraded fc27>fc28 

grub-customizer
 *** initializing (w/o specified bootloader type)…
   * reading partition info…
/usr/include/c++/8/bits/basic_string.h:1048: std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::operator[](std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type) [with _CharT = char; _Traits = std::char_traits<char>; _Alloc = std::allocator<char>; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference = char&; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type = long unsigned int]: Assertion '__pos <= size()' failed.

Comment 6 fengg.ae 2018-05-03 18:12:45 UTC
Same here. Fresh Install of Fedora 28 Mate Spin

grub-customizer 
 *** initializing (w/o specified bootloader type)…
   * reading partition info…
/usr/include/c++/8/bits/basic_string.h:1048: std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::operator[](std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type) [with _CharT = char; _Traits = std::char_traits<char>; _Alloc = std::allocator<char>; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference = char&; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type = long unsigned int]: Assertion '__pos <= size()' failed.

Comment 7 Netzmeister 2018-05-03 19:40:59 UTC
(In reply to Netzmeister from comment #4)
> I have the same Problem. Fedora 28 Workstation (GNOME with Wayland and XORG)

It happens after upgrade from fc27 to fc28

Comment 8 Jan Stárek 2018-05-04 16:01:42 UTC
Same here. After upgrading from fc27 to fc28 I have following error:

grub-customizer 
 *** initializing (w/o specified bootloader type)…
   * reading partition info…
/usr/include/c++/8/bits/basic_string.h:1048: std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::operator[](std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type) [with _CharT = char; _Traits = std::char_traits<char>; _Alloc = std::allocator<char>; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference = char&; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type = long unsigned int]: Assertion '__pos <= size()' failed.

Comment 9 Vasiliy Glazov 2018-05-04 18:41:29 UTC
*** Bug 1575089 has been marked as a duplicate of this bug. ***

Comment 10 Vasiliy Glazov 2018-05-08 15:38:46 UTC
*** Bug 1576031 has been marked as a duplicate of this bug. ***

Comment 11 Niranjan 2018-05-09 14:21:06 UTC
Reporting the same issue here (after upgrading to FC28 from FC27)

 *** initializing (w/o specified bootloader type)…
   * reading partition info…
/usr/include/c++/8/bits/basic_string.h:1048: std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::operator[](std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type) [with _CharT = char; _Traits = std::char_traits<char>; _Alloc = std::allocator<char>; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference = char&; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type = long unsigned int]: Assertion '__pos <= size()' failed.
Aborted (core dumped)

Comment 12 Vasiliy Glazov 2018-05-10 06:15:29 UTC
If anyone could help me investigate the problem, that would be fine. Upstream is silent.
May be it problem with GCC 8 or glibc.

Comment 13 Vasiliy Glazov 2018-05-10 13:50:27 UTC
*** Bug 1576835 has been marked as a duplicate of this bug. ***

Comment 14 Mic 2018-05-11 06:06:36 UTC
Hi,
Happy to help debug, I encounter the bug. Let me know what you need.
Mic

Comment 15 Vasiliy Glazov 2018-05-11 06:10:17 UTC
(In reply to Michael Monerau from comment #14)
> Hi,
> Happy to help debug, I encounter the bug. Let me know what you need.
> Mic

If I knew what I needed, I would have done it myself :)

Comment 16 Mic 2018-05-11 06:13:15 UTC
(In reply to Vasiliy Glazov from comment #15)
> (In reply to Michael Monerau from comment #14)
> > Hi,
> > Happy to help debug, I encounter the bug. Let me know what you need.
> > Mic
> 
> If I knew what I needed, I would have done it myself :)

Ah ok, I thought you couldn't reproduce the bug :)

Comment 17 Vasiliy Glazov 2018-05-19 06:28:38 UTC
*** Bug 1579923 has been marked as a duplicate of this bug. ***

Comment 18 Geoff Goas 2018-05-23 00:45:21 UTC
I am encountering a similar error in Cisco AnyConnect VPN client after upgrading from Fedora 27 to 28:

/builddir/build/BUILD/gcc-8.1.1-20180502/obj-x86_64-redhat-linux/x86_64-redhat-linux/libstdc++-v3/include/bits/basic_string.h:3965: std::basic_string<_CharT, _Traits, _Alloc>::reference std::basic_string<_CharT, _Traits, _Alloc>::operator[](std::basic_string<_CharT, _Traits, _Alloc>::size_type) [with _CharT = char; _Traits = std::char_traits<char>; _Alloc = std::allocator<char>; std::basic_string<_CharT, _Traits, _Alloc>::reference = char&; std::basic_string<_CharT, _Traits, _Alloc>::size_type = long unsigned int]: Assertion '__pos <= size()' failed.

Comment 19 Vasiliy Glazov 2018-05-28 09:29:54 UTC
*** Bug 1583132 has been marked as a duplicate of this bug. ***

Comment 20 Gurenko Alex 2018-05-31 12:22:27 UTC
Same problem on KDE spin that was upgraded from F27 to F28.

Old package from https://kojipkgs.fedoraproject.org//packages/grub-customizer/5.0.6/6.fc28/x86_64/grub-customizer-5.0.6-6.fc28.x86_64.rpm seems to work just fine.

Comment 21 daniele356 2018-05-31 15:39:09 UTC
(In reply to Gurenko Alex from comment #20)
> Same problem on KDE spin that was upgraded from F27 to F28.
> 
> Old package from
> https://kojipkgs.fedoraproject.org//packages/grub-customizer/5.0.6/6.fc28/
> x86_64/grub-customizer-5.0.6-6.fc28.x86_64.rpm seems to work just fine.

It works for me also

Comment 22 ben 2018-05-31 16:06:34 UTC
The koji package gave me a bad key error.

> https://kojipkgs.fedoraproject.org//packages/grub-customizer/5.0.6/6.fc28/

Found 1 from fc25 ver. 5.0.6.1 that works, I'll look around in my package cashes from previous installs for a more up2date version though.

Why didn't I do this before!

Comment 23 Richard Morehouse 2018-05-31 22:12:38 UTC
grub-customizer-5.0.6-6.fc28.x86_64.rpm from koji works for me on KDE as well

Comment 24 ben 2018-06-01 10:59:00 UTC
Comment 22 (update)

Yes the koji package works (now!)

Comment 25 Vasiliy Glazov 2018-06-17 08:52:29 UTC
5.0.8 released. I will build it tomorrow.

Comment 26 Fedora Update System 2018-06-18 07:00:18 UTC
grub-customizer-5.0.8-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-8cc7efc292

Comment 27 Fedora Update System 2018-06-18 07:00:54 UTC
grub-customizer-5.0.8-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d1dda3fac1

Comment 28 Fedora Update System 2018-06-18 07:01:15 UTC
grub-customizer-5.0.8-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-260bec0bea

Comment 29 Fedora Update System 2018-06-18 14:51:23 UTC
grub-customizer-5.0.8-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-8cc7efc292

Comment 30 Fedora Update System 2018-06-18 17:08:08 UTC
grub-customizer-5.0.8-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d1dda3fac1

Comment 31 Fedora Update System 2018-06-18 17:08:33 UTC
grub-customizer-5.0.8-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-260bec0bea

Comment 32 Richard Morehouse 2018-06-20 01:00:03 UTC
grub-customizer-5.0.8-1.fc28 worked for me

Comment 33 ben 2018-06-20 10:08:38 UTC
as previous comment 5.0.8 all good. 
Obtained from here;
https://apps.fedoraproject.org/packages/grub-customizer/builds

Comment 34 daniele356 2018-06-20 10:51:29 UTC
This new version works for me also!

Comment 35 Vasiliy Glazov 2018-06-20 10:58:30 UTC
If you want to see it in stable repo as soon as posible please add carma here https://bodhi.fedoraproject.org/updates/FEDORA-2018-d1dda3fac1

Comment 36 ben 2018-06-20 11:08:46 UTC
couldn't find the karma (carma) button? but gave feedback

Comment 37 Vasiliy Glazov 2018-06-20 11:10:17 UTC
redfenix, Just set +1 on "Is the update generally functional?" at the bottom of this page.
karma :)

Comment 38 Netzmeister 2018-06-20 17:03:00 UTC
(In reply to ben from comment #33)
> as previous comment 5.0.8 all good. 
> Obtained from here;
> https://apps.fedoraproject.org/packages/grub-customizer/builds

Hi there... Thank you for your effort! It works for me! Kind regards.

Comment 39 ben 2018-06-20 17:23:09 UTC
(In reply to Netzmeister from comment #38)

> 
> Hi there... Thank you for your effort! It works for me! Kind regards.

Thanks to the efforts of Vasiliy be sure to add the there;(to get this pushed for Updates channel)
karmahttps://bodhi.fedoraproject.org/updates/FEDORA-2018-d1dda3fac1

Comment 40 Fedora Update System 2018-06-26 16:06:51 UTC
grub-customizer-5.0.8-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 41 Fedora Update System 2018-06-26 17:34:00 UTC
grub-customizer-5.0.8-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 42 Fedora Update System 2018-07-03 12:54:02 UTC
grub-customizer-5.0.8-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.