Bug 1593885 - Fedora Rawhide VirtualBox freeze in graphical target
Summary: Fedora Rawhide VirtualBox freeze in graphical target
Keywords:
Status: CLOSED DUPLICATE of bug 1575328
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-21 18:47 UTC by marcin82
Modified: 2018-09-02 18:07 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-02 18:07:48 UTC
Type: Bug


Attachments (Terms of Use)

Description marcin82 2018-06-21 18:47:27 UTC
System is up to date with newest kernel. After start as VirtualBox geust doesn't achieve graphical target.

Information about guest system:
===============================

[root@rawhide ~]# grep vboxvideo /var/log/Xorg.0.log
[   358.336] (==) Matched vboxvideo as autoconfigured driver 0
[   358.336] (II) LoadModule: "vboxvideo"
[   358.337] (WW) Warning, couldn't open module vboxvideo
[   358.337] (EE) Failed to load module "vboxvideo" (module does not exist, 0)

[root@rawhide ~]# grep -E 'EE|WW' /var/log/Xorg.0.log
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   358.337] (WW) Warning, couldn't open module vboxvideo
[   358.337] (EE) Failed to load module "vboxvideo" (module does not exist, 0)
[   358.340] (WW) Falling back to old probe method for fbdev

[root@rawhide ~]# cat /var/log/lxdm.log
** Message: 20:23:28.270: 1529605408: add xserver watch


X.Org X Server 1.20.0
X Protocol Version 11, Revision 0
Build Operating System:  4.16.8-300.fc28.x86_64 
Current Operating System: Linux rawhide 4.18.0-0.rc1.git1.1.fc29.x86_64 #1 SMP Tue Jun 19 14:26:19 UTC 2018 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.18.0-0.rc1.git1.1.fc29.x86_64 root=UUID=6a186999-81b7-4325-9404-920effd8d997 ro
Build Date: 12 June 2018  01:44:39PM
Build ID: xorg-x11-server 1.20.0-4.fc29 
Current version of pixman: 0.34.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jun 21 20:23:28 2018
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
pci id for fd 16: 80ee:beef, driver (null)

[root@rawhide ~]# uname -r
4.18.0-0.rc1.git1.1.fc29.x86_64
[root@rawhide ~]# nohash /etc/default/grub 
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_CMDLINE_LINUX=""
GRUB_DISABLE_RECOVERY="true"
GRUB_TERMINAL=gfxterm
GRUB_GFXMODE=1280x1024
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_CMDLINE_LINUX_DEFAULT="fbcon=scrollback:2048k audit=0"

[root@rawhide ~]# lsmod | grep -i vbox
vboxvideo              45056  1
ttm                   135168  1 vboxvideo
vboxguest              45056  1
drm_kms_helper        196608  1 vboxvideo
drm                   565248  4 drm_kms_helper,vboxvideo,ttm

[root@rawhide ~]# find /usr/lib/modules -iname vbox*.ko.xz
/usr/lib/modules/4.18.0-0.rc1.git0.1.fc29.x86_64+debug/kernel/drivers/staging/vboxvideo/vboxvideo.ko.xz
/usr/lib/modules/4.18.0-0.rc1.git0.1.fc29.x86_64+debug/kernel/drivers/virt/vboxguest/vboxguest.ko.xz
/usr/lib/modules/4.18.0-0.rc0.git10.1.fc29.x86_64/kernel/drivers/staging/vboxvideo/vboxvideo.ko.xz
/usr/lib/modules/4.18.0-0.rc0.git10.1.fc29.x86_64/kernel/drivers/virt/vboxguest/vboxguest.ko.xz
/usr/lib/modules/4.18.0-0.rc1.git0.1.fc29.x86_64/kernel/drivers/staging/vboxvideo/vboxvideo.ko.xz
/usr/lib/modules/4.18.0-0.rc1.git0.1.fc29.x86_64/kernel/drivers/virt/vboxguest/vboxguest.ko.xz
/usr/lib/modules/4.18.0-0.rc1.git1.1.fc29.x86_64/kernel/drivers/staging/vboxvideo/vboxvideo.ko.xz
/usr/lib/modules/4.18.0-0.rc1.git1.1.fc29.x86_64/kernel/drivers/virt/vboxguest/vboxguest.ko.xz

[root@rawhide ~]# rpm -qa virtualbox-guest-additions
virtualbox-guest-additions-5.2.12-1.fc29.x86_64


Information about host system:
==============================

[root@arch ~]# uname -r
4.17.2-1-ARCH

[root@arch ~]# pacman -Qs virtualbox
local/virtualbox 5.2.12-2
    Powerful x86 virtualization for enterprise as well as home use
local/virtualbox-host-modules-arch 5.2.12-10
    Virtualbox host kernel modules for Arch Kernel

Image:
======
https://image.ibb.co/dFnfAT/rawhide.png

Comment 1 marcin82 2018-06-21 19:43:37 UTC
It's important ... forget it. Logs are taken during ssh session - "text" system works, but not X11, Xfce with result on screenshot.

Comment 2 Jan Kurik 2018-08-14 09:57:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 3 Hans de Goede 2018-09-02 18:07:48 UTC
I believe that this is a mesa issue which is fixed by this commit:

https://cgit.freedesktop.org/mesa/mesa/commit/?id=9baff597ce021f7691187b0d1d1bbc16d07b13e1

I'm currently working on doing a mesa build for f29 which includes this fix, the mesa problem which is the root cause of the Xorg crash is being tracked in bug 1575328, I'm marking this bug as a duplicate of that.

*** This bug has been marked as a duplicate of bug 1575328 ***


Note You need to log in before you can comment on or make changes to this bug.