Bug 1575340 - [abrt] systemd: log_assert_failed_unreachable_realm(): systemd killed by SIGABRT
Summary: [abrt] systemd: log_assert_failed_unreachable_realm(): systemd killed by SIGABRT
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:3ffda47c15ee39cff1c5a74599e...
: 1575350 1576084 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-06 05:21 UTC by Vint1988
Modified: 2018-07-18 10:52 UTC (History)
6 users (show)

Fixed In Version: systemd-238-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-18 10:52:38 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (12.12 KB, text/plain)
2018-05-06 05:21 UTC, Vint1988
no flags Details
File: cgroup (355 bytes, text/plain)
2018-05-06 05:21 UTC, Vint1988
no flags Details
File: core_backtrace (3.42 KB, text/plain)
2018-05-06 05:21 UTC, Vint1988
no flags Details
File: cpuinfo (1.26 KB, text/plain)
2018-05-06 05:21 UTC, Vint1988
no flags Details
File: dso_list (3.10 KB, text/plain)
2018-05-06 05:21 UTC, Vint1988
no flags Details
File: environ (297 bytes, text/plain)
2018-05-06 05:21 UTC, Vint1988
no flags Details
File: limits (1.29 KB, text/plain)
2018-05-06 05:21 UTC, Vint1988
no flags Details
File: maps (15.19 KB, text/plain)
2018-05-06 05:21 UTC, Vint1988
no flags Details
File: mountinfo (3.64 KB, text/plain)
2018-05-06 05:21 UTC, Vint1988
no flags Details
File: open_fds (1.60 KB, text/plain)
2018-05-06 05:21 UTC, Vint1988
no flags Details
File: proc_pid_status (1.24 KB, text/plain)
2018-05-06 05:21 UTC, Vint1988
no flags Details
File: var_log_messages (8.41 KB, text/plain)
2018-05-06 05:21 UTC, Vint1988
no flags Details

Description Vint1988 2018-05-06 05:21:11 UTC
Version-Release number of selected component:
systemd-238-7.fc28.1

Additional info:
reporter:       libreport-2.9.5
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd --user
crash_function: log_assert_failed_unreachable_realm
executable:     /usr/lib/systemd/systemd
journald_cursor: s=c914debce927456089778c6d919880d6;i=1e5b;b=6b4a5aed11934dcd85ff384cb355d82e;m=110894b48;t=56b66f158ac6b;x=7231780b4bdc469d
kernel:         4.16.5-300.fc28.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            42

Truncated backtrace:
Thread no. 1 (8 frames)
 #2 log_assert_failed_unreachable_realm at ../src/basic/log.c:838
 #3 bus_process_internal at ../src/libsystemd/sd-bus/sd-bus.c:2978
 #4 sd_bus_process at ../src/libsystemd/sd-bus/sd-bus.c:2994
 #5 bus_ensure_running at ../src/libsystemd/sd-bus/sd-bus.c:2056
 #6 sd_bus_flush at ../src/libsystemd/sd-bus/sd-bus.c:3102
 #7 destroy_bus at ../src/core/dbus.c:1100
 #8 bus_done at ../src/core/dbus.c:1138
 #9 manager_free at ../src/core/manager.c:1203

Comment 1 Vint1988 2018-05-06 05:21:19 UTC
Created attachment 1432237 [details]
File: backtrace

Comment 2 Vint1988 2018-05-06 05:21:20 UTC
Created attachment 1432238 [details]
File: cgroup

Comment 3 Vint1988 2018-05-06 05:21:23 UTC
Created attachment 1432239 [details]
File: core_backtrace

Comment 4 Vint1988 2018-05-06 05:21:25 UTC
Created attachment 1432240 [details]
File: cpuinfo

Comment 5 Vint1988 2018-05-06 05:21:27 UTC
Created attachment 1432241 [details]
File: dso_list

Comment 6 Vint1988 2018-05-06 05:21:29 UTC
Created attachment 1432242 [details]
File: environ

Comment 7 Vint1988 2018-05-06 05:21:31 UTC
Created attachment 1432243 [details]
File: limits

Comment 8 Vint1988 2018-05-06 05:21:33 UTC
Created attachment 1432244 [details]
File: maps

Comment 9 Vint1988 2018-05-06 05:21:35 UTC
Created attachment 1432245 [details]
File: mountinfo

Comment 10 Vint1988 2018-05-06 05:21:37 UTC
Created attachment 1432246 [details]
File: open_fds

Comment 11 Vint1988 2018-05-06 05:21:39 UTC
Created attachment 1432247 [details]
File: proc_pid_status

Comment 12 Vint1988 2018-05-06 05:21:41 UTC
Created attachment 1432248 [details]
File: var_log_messages

Comment 13 Zbigniew Jędrzejewski-Szmek 2018-07-18 10:38:34 UTC
*** Bug 1576084 has been marked as a duplicate of this bug. ***

Comment 14 Zbigniew Jędrzejewski-Szmek 2018-07-18 10:38:52 UTC
*** Bug 1575350 has been marked as a duplicate of this bug. ***

Comment 15 Zbigniew Jędrzejewski-Szmek 2018-07-18 10:52:38 UTC
There was a significant reworking of the bus code in https://github.com/systemd/systemd/commit/4502c40399. That patch is in systemd-238, and I was confused, because the backtraces in those three bugs show the old call sequence. So what must have happened here, is that an upgrade from older systemd was made to systemd-238, and then the older systemd crashed during reexec.

That said, there seems to be a memory corruption here, and destroy_bus is called on a bus that has already been deallocated. I think/hope the patch above fixes this.

There's another issue with the code, uncovered by this failure. See upstream PR https://github.com/systemd/systemd/pull/9640. Nevertheless, that patch wouldn't fix this problem anyway.

I'll close this on the assumption that 4502c40399 is enough to fix this. If a similar backtrace happens again, this will mean I was wrong ;)


Note You need to log in before you can comment on or make changes to this bug.