Bug 157550 - GtkAda has ExcludeArch PPC because there is no gcc-gnat for PPC
GtkAda has ExcludeArch PPC because there is no gcc-gnat for PPC
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: GtkAda (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On: 158458
Blocks: F-ExcludeArch-ppc
  Show dependency treegraph
 
Reported: 2005-05-12 12:43 EDT by Thorsten Leemhuis
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-06 11:23:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2005-05-12 12:43:41 EDT
Adding ExcludeArch PPC to spec because there is no gcc-gnat for PPC currently;
gcc-gnat is a BR.
Comment 1 Colin Charles 2005-05-17 07:00:06 EDT
Why is there no gcc-gnat, and does someone want to file a bug against that to
see if that can work in Core? Thanks
Comment 2 Thorsten Leemhuis 2005-05-17 09:43:41 EDT
(In reply to comment #1)
> Why is there no gcc-gnat,
rpm -qp --changelog gcc-gnat-4.0.0-2.x86_64.rpm 

* Fr Mär 04 2005 Jakub Jelinek  <jakub@redhat.com> 4.0.0-0.31
[...]
- temporarily disable Ada on ppc, where there are bootstrap comparison
  failures

> and does someone want to file a bug against that to
> see if that can work in Core? 

Someone != me 

;-) I have enough to do with x86_64 already, sorry
Comment 3 David Woodhouse 2006-12-30 08:44:55 EST
GtkAda works fine with gcc-gnat-4.1.1 in FC-6, and I've uploaded it to
ftp://ftp.infradead.org/pub/fc6-ada/

We just need to get gnat built into the buildroot; see bug 158458.

Comment 4 David Woodhouse 2007-01-05 05:21:52 EST
As of gcc-4.1.1-51 we have gnat in rawhide. Please build GtkAda for PPC.
Comment 5 Gérard Milmeister 2007-01-05 15:56:18 EST
Tried to build on ppc-devel. There is no gnat yet.
Comment 6 David Woodhouse 2007-01-05 18:36:03 EST
Please try again. The ghdl build (bug #174720) has already completed successfully.
Comment 7 Gérard Milmeister 2007-01-06 11:23:55 EST
Build for ppc in devel.
Comment 8 David Woodhouse 2007-01-06 21:08:54 EST
Thanks.

Note You need to log in before you can comment on or make changes to this bug.