Bug 1575787 - R-preprocessCore fails to install (is linked against older libgfortran)
Summary: R-preprocessCore fails to install (is linked against older libgfortran)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: R-preprocessCore
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Pierre-YvesChibon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 23:55 UTC by Ben Webb
Modified: 2018-07-10 11:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-10 11:01:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Ben Webb 2018-05-07 23:55:28 UTC
Description of problem:

It is not possible to install the R-preprocessCore package on an x86_64 Fedora 28 system, as it is linked against libgfortran.so.4, which no package provides (the current version of libgfortran.so is .5). Looks like the package was not rebuilt for Fedora 28 and instead the (non-functional) Fedora 27 package is provided.


Version-Release number of selected component (if applicable):
R-preprocessCore-1.38.1-3.fc27.x86_64

How reproducible:
Always

Steps to Reproduce:
1. dnf install R-preprocessCore

Actual results:

dnf fails with the following output:

Error: 
 Problem: conflicting requests
  - nothing provides libgfortran.so.4 needed by R-preprocessCore-1.38.1-3.fc27.i686
  - nothing provides libgfortran.so.4()(64bit) needed by R-preprocessCore-1.38.1-3.fc27.x86_64


Expected results:
Package is installed successfully.

Comment 1 Ben Webb 2018-05-08 19:47:41 UTC
Looks like this was caused by bug #1555561, FTBFS for F28. However, I just took the SRPM from F27 (R-preprocessCore-1.38.1-3.fc27.src.rpm) and rebuilt it in an F28 mock environment and it built just fine (making R-preprocessCore-1.38.1-3.fc28.x86_64.rpm, which installs with no issues). So perhaps this was just a transient Koji failure, and poking it again should trivially fix this?

Comment 2 Bogdan Costescu 2018-05-11 09:09:37 UTC
This seems to be a more general problem, several more R packages have the same problem:

R-lmtest-0.9.35-3.fc27.x86_64
R-maanova-1.46.1-3.fc27.x86_64
R-msm-1.6.4-3.fc27.x86_64
R-shogun-6.0.0-5.fc27.x86_64
R-statmod-1.4.20-7.fc27.x86_64
R-waveslim-1.7.5-6.fc27.x86_64
R-mvtnorm-1.0.6-3.fc27.x86_64

plus there are packages that depend on the those listed and which can't be installed. One can easily reproduce this with something line 'dnf install R-*'.

Was there a repo closure run before releasing F28???

Comment 3 Bogdan Costescu 2018-05-11 09:12:41 UTC
And seemingly there is a related bug report:

https://bugzilla.redhat.com/show_bug.cgi?id=1575940

Comment 4 Pierre-YvesChibon 2018-07-10 11:01:02 UTC
We now have R-preprocessCore 1.42.0 which I believe fix this issue.

If it does not, please re-open this ticket.


Note You need to log in before you can comment on or make changes to this bug.