Bug 1576031 - Process 4220 (grub-customizer) dumped core
Summary: Process 4220 (grub-customizer) dumped core
Keywords:
Status: CLOSED DUPLICATE of bug 1570260
Alias: None
Product: Fedora
Classification: Fedora
Component: grub-customizer
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vasiliy Glazov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 15:34 UTC by Mike Lear
Modified: 2018-05-08 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-08 15:38:46 UTC
Type: Bug


Attachments (Terms of Use)

Description Mike Lear 2018-05-08 15:34:53 UTC
Description of problem:
As root started grub-customizer which crashed. Removed and re-installed with dnf
but still crashed . Journal -xb shows the following:
Process 4220 (grub-customizer) of user 0 dumped core.

Stack trace of thread 4220:
#0  0x00007f70c9bd1f4b raise (libc.so.6)
#1  0x00007f70c9bbc591 abort (libc.so.6)
#2  0x00005582573e5a28 _ZSt20__replacement_assertPKciS0_S0_ (grub-customizer)
#3  0x000055825741a011 ZN16Model_MountTable3addERKNSt7__cxx1112basic_stringIcSt>
#4  0x0000558257427b05 ZN16Model_MountTable8loadDataEP8_IO_FILERKNSt7__cxx1112b>
#5  0x00005582574285fe ZN16Model_MountTable8loadDataERKNSt7__cxx1112basic_strin>
#6  0x000055825742df16 _ZN14MainController4initEv (grub-customizer)
#7  0x000055825742eabd _ZN14MainController10initActionEv (grub-customizer)
#8  0x00005582573d5c59 main (grub-customizer)
#9  0x00007f70c9bbe1bb __libc_start_main (libc.so.6)
#10 0x00005582573d638a _start (grub-customizer)
Stack trace of thread 4222:
#0  0x00007f70c9c8a929 __poll (libc.so.6)
#1  0x00007f70cb495b06 g_main_context_iterate.isra.21 (libglib-2.0.so.0)
#2  0x00007f70cb495ec2 g_main_loop_run (libglib-2.0.so.0)
#3  0x00007f70cc3fc60a gdbus_shared_thread_func (libgio-2.0.so.0)
#4  0x00007f70cb4bdcea g_thread_proxy (libglib-2.0.so.0)
#5  0x00007f70c849f564 start_thread (libpthread.so.0)
#6  0x00007f70c9c9531f __clone (libc.so.6)
Stack trace of thread 4221:
#0  0x00007f70c9c8a929 __poll (libc.so.6)
#1  0x00007f70cb495b06 g_main_context_iterate.isra.21 (libglib-2.0.so.0)
#2  0x00007f70cb495c30 g_main_context_iteration (libglib-2.0.so.0)
#3  0x00007f70cb495c81 glib_worker_main (libglib-2.0.so.0)
#4  0x00007f70cb4bdcea g_thread_proxy (libglib-2.0.so.0)
#5  0x00007f70c849f564 start_thread (libpthread.so.0)
#6  0x00007f70c9c9531f __clone (libc.so.6)
Stack trace of thread 4224:
#0  0x00007f70c9c8fdf9 syscall (libc.so.6)
#1  0x00007f70cb4dc44e g_cond_wait_until (libglib-2.0.so.0)
#2  0x00007f70cb4680e1 g_async_queue_pop_intern_unlocked (libglib-2.0.so.0)
#3  0x00007f70cb4686d0 g_async_queue_timeout_pop (libglib-2.0.so.0)
#4  0x00007f70cb4be791 g_thread_pool_thread_proxy (libglib-2.0.so.0)
#5  0x00007f70cb4bdcea g_thread_proxy (libglib-2.0.so.0)
#6  0x00007f70c849f564 start_thread (libpthread.so.0)
#7  0x00007f70c9c9531f __clone (libc.so.6)
-- Subject: Process 4220 (grub-customizer) dumped core
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: man:core(5)
--
-- Process 4220 (grub-customizer) crashed and dumped core.
--
-- This usually indicates a programming error in the crashing program and
-- should be reported to its vendor as a bug.


Version-Release number of selected component (if applicable):
grub-customizer-5.0.6-7.fc28.x86_64

How reproducible:
run program as root or as a group wheel user

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vasiliy Glazov 2018-05-08 15:38:46 UTC

*** This bug has been marked as a duplicate of bug 1570260 ***


Note You need to log in before you can comment on or make changes to this bug.