Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1576069 - [RFE] Need user friendly virt-who message when it is unable to connect to the satellite server [NEEDINFO]
Summary: [RFE] Need user friendly virt-who message when it is unable to connect to the...
Keywords:
Status: CLOSED DUPLICATE of bug 1576068
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: Eko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 17:24 UTC by Anitha Udgiri
Modified: 2019-10-28 07:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-28 15:12:16 UTC
Target Upstream Version:
sfroemer: needinfo? (candlepin-bugs)


Attachments (Terms of Use)

Comment 5 Yaniv Ferszt 2018-05-11 09:58:12 UTC
1. Proposed title of this feature request
virt-who - To report user friendly error if Satellite is not reachable


3. What is the nature and description of the request?
- While the Satellite Server is not reachable virt-who reports the following:
May  7 09:52:24 hostname /usr/bin/virt-who: [INFO] @virt.py:888 - Report for config "env/cmdline" gathered, placing in datastore
May  7 09:52:37 hostname /usr/bin/virt-who: [INFO] @virt.py:888 - Report for config "env/cmdline" gathered, placing in datastore
May  7 09:52:37 hostname /usr/bin/virt-who: [INFO] @virt.py:888 - Report for config "env/cmdline" gathered, placing in datastore
May  7 09:52:38 hostname /usr/bin/virt-who: [INFO] @virt.py:888 - Report for config "env/cmdline" gathered, placing in datastore
May  7 09:52:39 hostname python: detected unhandled Python exception in '/usr/bin/virt-who'
May  7 09:52:39 hostname virt-who: Traceback (most recent call last):
May  7 09:52:39 hostname virt-who: File "/usr/lib64/python2.7/site-packages/libvirt.py", line 4645, in _dispatchDomainEventCallbacks
May  7 09:52:39 hostname virt-who: cb(self, virDomain(self, _obj=dom), event, detail, opaque)
May  7 09:52:39 hostname virt-who: File "/usr/lib/python2.7/site-packages/virtwho/virt/libvirtd/libvirtd.py", line 221, in _callback
May  7 09:52:39 hostname virt-who: report = self._get_report()
May  7 09:52:39 hostname virt-who: File "/usr/lib/python2.7/site-packages/virtwho/virt/libvirtd/libvirtd.py", line 229, in _get_report
May  7 09:52:39 hostname virt-who: return DomainListReport(self.config, self._listDomains(), self._remote_host_id())
May  7 09:52:39 hostname virt-who: File "/usr/lib/python2.7/site-packages/virtwho/virt/libvirtd/libvirtd.py", line 274, in _listDomains
May  7 09:52:39 hostname virt-who: raise VirtError(str(e))
May  7 09:52:39 hostname virt-who: virtwho.virt.virt.VirtError: Domain not found: no domain with matching uuid '12345-12345-12345-12345-12345' (name)
May  7 09:52:39 hostname /usr/bin/virt-who: [ERROR] @virt.py:389 - Thread 'env/cmdline' fails with exception:#012libvirtError: invalid connection pointer in virConnectIsAlive
May  7 09:52:39 hostname /usr/bin/virt-who: [INFO] @virt.py:888 - Report for config "env/cmdline" gathered, placing in datastore
May  7 09:52:39 hostname /usr/bin/virt-who: [INFO] @virt.py:408 - Waiting 3600 seconds before performing action again 'env/cmdline'
May  7 09:52:55 hostname virt-who: Traceback (most recent call last):
May  7 09:52:55 hostname virt-who: File "/usr/lib64/python2.7/site-packages/libvirt.py", line 4645, in _dispatchDomainEventCallbacks
May  7 09:52:55 hostname virt-who: cb(self, virDomain(self, _obj=dom), event, detail, opaque)
May  7 09:52:55 hostname virt-who: File "/usr/lib/python2.7/site-packages/virtwho/virt/libvirtd/libvirtd.py", line 221, in _callback
May  7 09:52:55 hostname virt-who: report = self._get_report()
May  7 09:52:55 hostname virt-who: File "/usr/lib/python2.7/site-packages/virtwho/virt/libvirtd/libvirtd.py", line 229, in _get_report
May  7 09:52:55 hostname virt-who: return DomainListReport(self.config, self._listDomains(), self._remote_host_id())
May  7 09:52:55 hostname virt-who: File "/usr/lib/python2.7/site-packages/virtwho/virt/libvirtd/libvirtd.py", line 273, in _listDomains
May  7 09:52:55 hostname virt-who: self.virt.close()
May  7 09:52:55 hostname virt-who: File "/usr/lib64/python2.7/site-packages/libvirt.py", line 3523, in close
May  7 09:52:55 hostname virt-who: if ret == -1: raise libvirtError ('virConnectClose() failed', conn=self)
May  7 09:52:55 hostname virt-who: libvirt.libvirtError: invalid connection pointer in virConnectClose


4. Why does the customer need this? (List the business requirements here)
- Do not flood the messages with these error reports
- Just print "Could not connect to Satellite server A.domain.com"
- Provide a user friendly error message when the satellite is down so that these messages can be easily distinguished without needing to log a support call


5. How would the customer like to achieve this? (List the functional requirements here)
- Print "Could not connect to Satellite server A.domain.com"

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.
- disable communication betwen virt-who and the satellite. check the log files for the errors generated.

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?
no

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?
6 month

9. Is the sales team involved in this request and do they have any additional input?
no

10. List any affected packages or components.
virt-who

11. Would the customer be able to assist in testing this functionality if implemented?
yes

Comment 7 William Poteat 2019-05-28 15:12:16 UTC

*** This bug has been marked as a duplicate of bug 1576068 ***


Note You need to log in before you can comment on or make changes to this bug.