Bug 1576079 - FFU: openstack overcloud ffwd-upgrade run --yes generates inventory with wrong ansible_ssh_user
Summary: FFU: openstack overcloud ffwd-upgrade run --yes generates inventory with wron...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 13.0 (Queens)
Assignee: Carlos Camacho
QA Contact: Marius Cornea
URL:
Whiteboard:
: 1575445 (view as bug list)
Depends On:
Blocks: 1561169
TreeView+ depends on / blocked
 
Reported: 2018-05-08 18:14 UTC by Marius Cornea
Modified: 2018-06-27 13:56 UTC (History)
10 users (show)

Fixed In Version: python-tripleoclient-9.2.1-11.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:55:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1767379 None None None 2018-05-09 14:06:29 UTC
Launchpad 1769867 None None None 2018-05-09 14:28:11 UTC
Launchpad 1769974 None None None 2018-05-09 14:06:50 UTC
OpenStack gerrit 566960 'None' MERGED Add ssh-user to get_tripleo_ansible_inventory 2020-03-13 07:09:59 UTC
OpenStack gerrit 567013 'None' MERGED Add ssh-user to get_tripleo_ansible_inventory 2020-03-13 07:09:59 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:56:36 UTC

Description Marius Cornea 2018-05-08 18:14:28 UTC
openstack overcloud ffwd-upgrade run --yes generates inventory with wrong ansible_ssh_user:

(undercloud) [stack@undercloud-0 ~]$ openstack overcloud ffwd-upgrade run --yes
Warning! The TripleO Fast Forward Upgrade workflow is currently considered under development. In particular invocations of the ffwd-upgrade cli should be initially limited to development/test environments. Once and if you decide to use ffwd-upgrade in production, ensure you are adequately prepared with valid backup of your current deployment state.
Continuing fast forward upgrade
Started Mistral Workflow tripleo.package_update.v1.update_nodes. Execution ID: b00c6b64-b809-4556-b0ec-97f1d9b60a79
Waiting for messages on queue 'ffwdupgrade' with no timeout.
[u'Using /tmp/ansible-mistral-actionAS5fdE/ansible.cfg as config file',
 u' [WARNING]: Skipping unexpected key (hostvars) in group (_meta), only "vars",',
 u'"children" and "hosts" are valid',
 u'',
 u'PLAY [overcloud] ***************************************************************',
 u'',
 u'TASK [Gathering Facts] *********************************************************',
 u'fatal: [192.168.24.15]: UNREACHABLE! => {"changed": false, "msg": "Failed to connect to the host via ssh: Could not create directory \'/home/mistral/.ssh\'.\\r\\nWarning: Permanently added \'192.168.24.15\' (ECDSA) to the list of known hosts.\\r\\nPermission denied (publickey,gssapi-keyex,gssapi-with-mic).\\r\\n", "unreachable": true}',
 u'fatal: [192.168.24.13]: UNREACHABLE! => {"changed": false, "msg": "Failed to connect to the host via ssh: Could not create directory \'/home/mistral/.ssh\'.\\r\\nWarning: Permanently added \'192.168.24.13\' (ECDSA) to the list of known hosts.\\r\\nPermission denied (publickey,gssapi-keyex,gssapi-with-mic).\\r\\n", "unreachable": true}',
 u'fatal: [192.168.24.17]: UNREACHABLE! => {"changed": false, "msg": "Failed to connect to the host via ssh: Could not create directory \'/home/mistral/.ssh\'.\\r\\nWarning: Permanently added \'192.168.24.17\' (ECDSA) to the list of known hosts.\\r\\nPermission denied (publickey,gssapi-keyex,gssapi-with-mic).\\r\\n", "unreachable": true}',
 u'fatal: [192.168.24.19]: UNREACHABLE! => {"changed": false, "msg": "Failed to connect to the host via ssh: Could not create directory \'/home/mistral/.ssh\'.\\r\\nWarning: Permanently added \'192.168.24.19\' (ECDSA) to the list of known hosts.\\r\\nPermission denied (publickey,gssapi-keyex,gssapi-with-mic).\\r\\n", "unreachable": true}',
 u'fatal: [192.168.24.12]: UNREACHABLE! => {"changed": false, "msg": "Failed to connect to the host via ssh: Could not create directory \'/home/mistral/.ssh\'.\\r\\nWarning: Permanently added \'192.168.24.12\' (ECDSA) to the list of known hosts.\\r\\nPermission denied (publickey,gssapi-keyex,gssapi-with-mic).\\r\\n", "unreachable": true}',
 u'fatal: [192.168.24.10]: UNREACHABLE! => {"changed": false, "msg": "Failed to connect to the host via ssh: Could not create directory \'/home/mistral/.ssh\'.\\r\\nWarning: Permanently added \'192.168.24.10\' (ECDSA) to the list of known hosts.\\r\\nPermission denied (publickey,gssapi-keyex,gssapi-with-mic).\\r\\n", "unreachable": true}',
 u'fatal: [192.168.24.18]: UNREACHABLE! => {"changed": false, "msg": "Failed to connect to the host via ssh: Could not create directory \'/home/mistral/.ssh\'.\\r\\nWarning: Permanently added \'192.168.24.18\' (ECDSA) to the list of known hosts.\\r\\nPermission denied (publickey,gssapi-keyex,gssapi-with-mic).\\r\\n", "unreachable": true}',
 u'fatal: [192.168.24.23]: UNREACHABLE! => {"changed": false, "msg": "Failed to connect to the host via ssh: Could not create directory \'/home/mistral/.ssh\'.\\r\\nWarning: Permanently added \'192.168.24.23\' (ECDSA) to the list of known hosts.\\r\\nPermission denied (publickey,gssapi-keyex,gssapi-with-mic).\\r\\n", "unreachable": true}',
 u'',
 u'PLAY RECAP *********************************************************************',
 u'192.168.24.10 : ok=0 changed=0 unreachable=1 failed=0 ',
 u'192.168.24.12 : ok=0 changed=0 unreachable=1 failed=0 ',
 u'192.168.24.13 : ok=0 changed=0 unreachable=1 failed=0 ',
 u'192.168.24.15 : ok=0 changed=0 unreachable=1 failed=0 ',
 u'192.168.24.17 : ok=0 changed=0 unreachable=1 failed=0 ',
 u'192.168.24.18 : ok=0 changed=0 unreachable=1 failed=0 ',
 u'192.168.24.19 : ok=0 changed=0 unreachable=1 failed=0 ',
 u'192.168.24.23 : ok=0 changed=0 unreachable=1 failed=0 ',

[root@undercloud-0 stack]# grep ansible_ssh_user /tmp/ansible-mistral-actionAS5fdE/inventory.yaml
    ansible_ssh_user: overcloud
    ansible_ssh_user: overcloud
    ansible_ssh_user: overcloud
  vars: {ansible_ssh_user: overcloud}

Comment 1 Marios Andreou 2018-05-09 10:03:03 UTC
this is duplicate of BZ 1575445. I assigned it to myself but i saw that ccamacho landed https://review.openstack.org/#/c/566960/ so re-assigning back to him

Comment 2 Marios Andreou 2018-05-09 11:01:51 UTC
*** Bug 1575445 has been marked as a duplicate of this bug. ***

Comment 3 Marios Andreou 2018-05-09 14:26:01 UTC
adding https://review.openstack.org/#/c/567233/ for tracking since I closed BZ 1575445 as duplicate

Comment 4 Carlos Camacho 2018-05-09 15:43:10 UTC
We need blocker flags for proposing this downstream.

Comment 11 Sergii Golovatiuk 2018-05-24 08:21:00 UTC
The actual patch was not included, so I added the actual patch to package. It should be included to python-tripleoclient-9.2.1-11. Thus it requires retesting

Comment 14 errata-xmlrpc 2018-06-27 13:55:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.