Bug 1576254 - NetworkManager fails to configure IPV6 on network bridge
Summary: NetworkManager fails to configure IPV6 on network bridge
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.5
Hardware: x86_64
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 1575944
Blocks: 1578430
TreeView+ depends on / blocked
 
Reported: 2018-05-09 07:12 UTC by Beniamino Galvani
Modified: 2018-10-30 11:14 UTC (History)
20 users (show)

Fixed In Version: NetworkManager-1.10.2-15.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1575944
: 1578430 (view as bug list)
Environment:
Last Closed: 2018-10-30 11:13:09 UTC
Target Upstream Version:


Attachments (Terms of Use)
Reproducer (492 bytes, application/x-shellscript)
2018-05-10 08:25 UTC, Beniamino Galvani
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3207 0 None None None 2018-10-30 11:14:29 UTC

Description Beniamino Galvani 2018-05-09 07:12:17 UTC
+++ This bug was initially created as a clone of Bug #1575944 +++

To allow virtual machines to access the internet, I have created a bridge on my host computer. For use by the host itself, the bridge is set up to have a private IPv4 address (which is converted to an external address via NAT in my home router), a static private IPv6 address for local communication and a dynamic IPv6 address obtained via SLAAC for internet access.

This setup has worked well with Fedora 26 and 27, but with Fedora 28 the bridge device does not get any IPv6 assigned, not even a link-local one:

$ ifconfig bridge0
bridge0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.11  netmask 255.255.255.0  broadcast 192.168.0.255
        ether 00:25:22:06:b2:1c  txqueuelen 1000  (Ethernet)
        RX packets 4118  bytes 3503462 (3.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3613  bytes 448237 (437.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Contents of /etc/sysconfig/network-scripts/ifcfg-bridge0:

STP=no
BRIDGING_OPTS=multicast_snooping=0
TYPE=Bridge
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=none
IPADDR=192.168.0.11
PREFIX=24
GATEWAY=192.168.0.1
DNS1=192.168.0.1
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6ADDR=fd89:...:11/64 (truncated)
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
IPV6_PRIVACY=no
IPV6_ADDR_GEN_MODE=stable-privacy
NAME=bridge0
UUID=07f3c47c-0f92-41cc-ba84-34e4c8f02ab8
DEVICE=bridge0
ONBOOT=yes

Static and link-local addresses are assigned correctly with IPV6_AUTOCONF=no, but then of course the dynamic address for internet access is missing.

The issue does not occur on simple Ethernet interfaces without bridge.

--- Additional comment from Beniamino Galvani on 2018-05-09 09:00 CEST ---

Comment 2 Beniamino Galvani 2018-05-10 08:25:19 UTC
Created attachment 1434258 [details]
Reproducer

Comment 12 errata-xmlrpc 2018-10-30 11:13:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3207


Note You need to log in before you can comment on or make changes to this bug.