Bug 157626 - Unable to compile vanilla kernel
Summary: Unable to compile vanilla kernel
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-13 08:27 UTC by Dr. Tilmann Bubeck
Modified: 2015-01-04 22:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 00:55:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dr. Tilmann Bubeck 2005-05-13 08:27:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050504 Fedora/1.0.3-4 Firefox/1.0.3

Description of problem:
Unable to compile a fresh installed linux-2.6.7 with the default everything installation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
[root@station7 a]# tar xfj ../linux-2.6.7.tar.bz2
[root@station7 a]# cd linux-2.6.7/
[root@station7 linux-2.6.7]# make xconfig
  HOSTCC  scripts/basic/fixdep
  HOSTCC  scripts/basic/split-include
  HOSTCC  scripts/basic/docproc
  SHIPPED scripts/kconfig/zconf.tab.h
  HOSTCC  scripts/kconfig/conf.o
sed < scripts/kconfig/lkc_proto.h > scripts/kconfig/lkc_defs.h 's/P(\([^,]*\),.*/#define \1 (\*\1_p)/'
  HOSTCC  scripts/kconfig/kconfig_load.o
  HOSTCC  scripts/kconfig/mconf.o
scripts/kconfig/mconf.c:91: Fehler: statische Deklaration von >>current_menu<< folgt nicht-statischer Deklaration
scripts/kconfig/lkc.h:63: Fehler: vorherige Deklaration von >>current_menu<< war hier
make[1]: *** [scripts/kconfig/mconf.o] Fehler 1
make: *** [xconfig] Fehler 2
[root@station7 linux-2.6.7]# gcc -v
Es werden eingebaute Spezifikationen verwendet.
Ziel: i386-redhat-linux
Konfiguriert mit: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-languages=c,c++,objc,java,f95,ada --enable-java-awt=gtk --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre --host=i386-redhat-linux
Thread-Modell: posix
gcc-Version 4.0.0 20050423 (Red Hat 4.0.0-2)

 

Additional info:

Comment 1 Dr. Tilmann Bubeck 2005-05-14 20:28:13 UTC
This is most probably due to gcc4. However, you should mention this in the
release notes or something else...


Note You need to log in before you can comment on or make changes to this bug.