Bug 1576699 - unable to do vnc installation
Summary: unable to do vnc installation
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libxcb
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F29BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2018-05-10 08:15 UTC by lnie
Modified: 2018-08-13 18:19 UTC (History)
16 users (show)

Fixed In Version: tigervnc-1.8.0-9.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-13 18:19:54 UTC


Attachments (Terms of Use)
screenshot (59.56 KB, image/png)
2018-05-10 08:15 UTC, lnie
no flags Details
anaconda.log (2.44 KB, text/plain)
2018-05-10 08:16 UTC, lnie
no flags Details

Description lnie 2018-05-10 08:15:36 UTC
Created attachment 1434256 [details]
screenshot

Description of problem:
boot the installer with inst.vnc option added,then the installation will end up with "pane is dead",as shown in the attached picture.

Version-Release number of selected component (if applicable):
Fedora-Workstation-netinst-x86_64-Rawhide-20180506.n.0.iso

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2018-05-10 08:16:10 UTC
Created attachment 1434257 [details]
anaconda.log

Comment 2 Martin Kolman 2018-05-10 09:41:13 UTC
Looking at anaconda.log, there is:

07:53:22,768 ERR core.util: Failed to import module docker from path /usr/share/anaconda/addons/com_redhat_docker/ks/docker.py in collect: No module named 'pyanaconda.iutil'

But I think that might not be fatal & has likely been happening for a while already.

On the other hand the isys segfault visible on the screenshot seems like the most  likely reason why the Anaconda process died.

Comment 3 Fedora Blocker Bugs Application 2018-05-14 07:57:55 UTC
Proposed as a Blocker for 29-beta by Fedora user lnie using the blocker tracking app because:

 seems affects the basic criteria " When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces."

Comment 4 František Zatloukal 2018-05-14 22:23:07 UTC
Discussed during the 2018-05-14 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as it violates the following blocker criteria:

"When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces"

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-05-14/f29-blocker-review.2018-05-14-16.01.log.txt

Comment 5 Vendula Poncova 2018-05-15 09:46:09 UTC
The failure is caused by segfault in libxcb. The isys part is just a signal handler. Reassinging to libxcb.

Comment 6 Radek Vykydal 2018-06-06 07:03:44 UTC
This is blocking our nightly kickstart tests on rawhide.

Comment 7 Adam Jackson 2018-06-06 19:46:30 UTC
Xvnc's GLX init wasn't quite right, fixed.

Comment 8 Paul Whalen 2018-06-11 15:19:32 UTC
Verified working with compose Fedora-Rawhide-20180609.n.0

Comment 9 lnie 2018-06-25 04:55:52 UTC
This bug seems gone,but unable to do vnc installation with inst.vncpassword boot option.

Comment 10 lnie 2018-06-25 04:57:22 UTC
Please see #bz1592686 for more information,thanks.

Comment 11 Adam Williamson 2018-08-13 18:19:54 UTC
As that's a different bug, let's close this one.


Note You need to log in before you can comment on or make changes to this bug.