Bug 1592686 - the installer will hang there if inst.vncpassword boot option is added [NEEDINFO]
Summary: the installer will hang there if inst.vncpassword boot option is added
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 29
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Keywords:
: 1631093 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-19 06:55 UTC by lnie
Modified: 2019-02-19 21:38 UTC (History)
13 users (show)

Fixed In Version: anaconda-29.24.4-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-02-19 21:38:49 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
awilliam: needinfo? (lnie)


Attachments (Terms of Use)
anaconda.log (2.24 KB, text/plain)
2018-06-19 06:55 UTC, lnie
no flags Details
screenshot (31.84 KB, image/png)
2018-06-19 06:57 UTC, lnie
no flags Details
anaconda.log (2.16 KB, text/plain)
2018-06-19 09:53 UTC, lnie
no flags Details
dbus.log (3.12 KB, text/plain)
2018-06-19 09:54 UTC, lnie
no flags Details
ifcfg.log (2.13 KB, text/plain)
2018-06-19 09:55 UTC, lnie
no flags Details
storage.log (251 bytes, text/plain)
2018-06-19 09:56 UTC, lnie
no flags Details
program.log (927 bytes, text/plain)
2018-06-19 09:56 UTC, lnie
no flags Details
syslog (228.17 KB, text/plain)
2018-06-19 09:58 UTC, lnie
no flags Details
.treeinfo from Fedora rawhide of 2018-09-19 (1.18 KB, application/octet-stream)
2018-09-28 13:50 UTC, IBM Bug Proxy
no flags Details

Description lnie 2018-06-19 06:55:04 UTC
Created attachment 1452825 [details]
anaconda.log

Description of problem:
boot the installer with inst.vnc inst.vncpassword,the system will just hang there as shown in the attached screenshot,but if you just add the inst.vnc option,
the installer will be able to finish the installation.

Version-Release number of selected component (if applicable):
Fedora-Server-dvd-x86_64-Rawhide-20180615.n.0.iso
Fedora-Workstation-netinst-x86_64-Rawhide-20180615.n.0.iso

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2018-06-19 06:57 UTC
Created attachment 1452826 [details]
screenshot

Comment 2 Jiri Konecny 2018-06-19 08:13:53 UTC
Please attach all the logs from the tmp/*.log.

Thank you.

Comment 3 lnie 2018-06-19 09:53 UTC
Created attachment 1452859 [details]
anaconda.log

Comment 4 lnie 2018-06-19 09:54 UTC
Created attachment 1452860 [details]
dbus.log

Comment 5 lnie 2018-06-19 09:55 UTC
Created attachment 1452861 [details]
ifcfg.log

Comment 6 lnie 2018-06-19 09:56 UTC
Created attachment 1452862 [details]
storage.log

Comment 7 lnie 2018-06-19 09:56 UTC
Created attachment 1452863 [details]
program.log

Comment 8 lnie 2018-06-19 09:58 UTC
Created attachment 1452864 [details]
syslog

Comment 9 lnie 2018-06-25 04:50:46 UTC
Still see this bug with the latest Fedora-Workstation-netinst-x86_64-Rawhide-20180623.n.1.iso and Fedora-Server-dvd-x86_64-Rawhide-20180623.n.1.iso

Comment 10 Paul Whalen 2018-07-12 16:23:06 UTC
Also happens after setting a password on a text install (Fedora-Rawhide-20180707.n.2)

================================================================================
================================================================================

1) Start VNC
2) Use text mode

Please make a selection from the above ['c' to continue, 'q' to quit, 'r' to
refresh]: 1
================================================================================
================================================================================
VNC Password

Please provide VNC password (must be six to eight characters long).
You will have to type it twice. Leave blank for no password

Password: 
Password (confirm): 
11:15:44 Starting VNC...

Comment 11 Jan Kurik 2018-08-14 09:57:27 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 12 lnie 2018-09-03 04:38:51 UTC
Still happens with latest Fedora-Workstation-netinst-x86_64-29-20180901.n.0.iso

Comment 13 Fedora Blocker Bugs Application 2018-09-13 07:34:02 UTC
Proposed as a Blocker for 29-beta by Fedora user lnie using the blocker tracking app because:

 This seems affects the criteria:
When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces.

Comment 14 Adam Williamson 2018-09-13 08:07:06 UTC
I think I'd be -1, the criterion doesn't require that this specific feature (passworded VNC) work, and regular VNC without password works fine, I think.

Comment 15 Adam Williamson 2018-09-14 03:50:19 UTC
Discussed at 2018-09-13 Fedora 29 Beta Go/No-Go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2018-09-13/f29-beta-go_no_go-meeting.2018-09-13-17.00.html . Rejected as a blocker, as the criteria does not say anything about requiring password-protected VNC to work, only 'VNC'. inst.vnc works fine.

Obviously it'd still be desirable to fix this, but it doesn't seem to meet the requirements to be a blocker.

Comment 16 Vendula Poncova 2018-09-20 16:25:59 UTC
*** Bug 1631093 has been marked as a duplicate of this bug. ***

Comment 17 Vendula Poncova 2018-09-20 16:28:44 UTC
Fixed in the pull request: https://github.com/rhinstaller/anaconda/pull/1617

Comment 18 Vendula Poncova 2018-09-20 17:05:43 UTC
Anaconda with the fix fails with an error that is reported here: https://bugzilla.redhat.com/show_bug.cgi?id=1631483

Comment 19 IBM Bug Proxy 2018-09-28 13:50:34 UTC
Created attachment 1488073 [details]
.treeinfo from Fedora rawhide of 2018-09-19

Comment 20 Adam Williamson 2019-01-18 22:18:27 UTC
lnie, can you check if this is working correctly in current Rawhide? Thanks!

Comment 21 Paul Whalen 2019-02-19 21:27:49 UTC
VNC password option confirmed working with a text install of Fedora-Rawhide-20190217.n.0

Comment 22 Adam Williamson 2019-02-19 21:38:49 UTC
Then we can go ahead and close this, nothing else is needed. Thanks!


Note You need to log in before you can comment on or make changes to this bug.