Bug 1576738 - goferd errors in /var/log/messages if goferd is installed on host not managed by satellite
Summary: goferd errors in /var/log/messages if goferd is installed on host not managed...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: katello-agent
Version: 6.0.0
Hardware: Unspecified
OS: All
unspecified
high
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Gaurav Talreja
URL:
Whiteboard:
: 1711320 1756792 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 09:47 UTC by Gajanan
Modified: 2020-11-18 20:57 UTC (History)
24 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1613231 (view as bug list)
Environment:
Last Closed: 2020-11-18 20:57:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1613231 0 unspecified CLOSED goferd errors in /var/log/messages of Red Hat Virtualization Host 2021-02-22 00:41:40 UTC
Red Hat Knowledge Base (Solution) 3391431 0 None None None 2018-05-10 10:03:43 UTC
Red Hat Knowledge Base (Solution) 4452121 0 None None None 2019-09-30 12:57:10 UTC

Internal Links: 1613231

Comment 1 Ryan Barry 2018-05-11 03:53:21 UTC
We don't modify platform files (such as katelloplugin.conf). Moving components to katello for handling.

Comment 11 Wei Wang 2018-05-23 04:23:33 UTC
Test Version:
rhvh-4.2.3.0-0.20180518.0
imgbased-1.0.16-0.1.el7ev.noarch
gofer-2.7.7-2.el7sat.noarch
subscription-manager-1.20.11-1.el7_5.x86_64
katello-agent-2.9.0.1-1.el7sat.noarch

Test Steps:
1. Clean install rhvh-4.2.3.0-0.20180518.0
2. Register RHVH to RHSM
3. Check the log file /var/log/messages

Results:
Customer issue occurs.
May 23 12:19:02 dhcp-9-130 goferd: [ERROR][worker-0] gofer.messaging.adapter.connect:33 - connect: proton+amqps://subscription.rhsm.redhat.com:5647, failed: Connection amqps://subscription.rhsm.redhat.com:5647 disconnected

The bug can be reproduced from QE.

Comment 12 Sandro Bonazzola 2018-08-07 09:12:05 UTC
We're going to workaround on RHV-H side disabling the service / removing it form enabled services preset

Comment 13 Sandro Bonazzola 2018-08-07 09:17:31 UTC
moved to satellite so they can track the issue on their side while we workaround it on RHV side.

Comment 21 Sandro Bonazzola 2018-09-06 11:22:56 UTC
We are tracking RHV-H workaround in bug #1613231. Please keep this on gofer side and either close wontfix/notabug or solve.
Note this will be workarounded on RHV-H side but will still be an issue in RHEL hosts managed by RHV-M.

Comment 25 Klaas Demter 2019-04-01 13:30:28 UTC
Are there any plans to fix this for a rhel based rhv host? This issue is about to turn one year old :)

Comment 26 Ryan Barry 2019-05-18 00:12:40 UTC
*** Bug 1711320 has been marked as a duplicate of this bug. ***

Comment 27 Sandro Bonazzola 2019-09-30 12:57:11 UTC
*** Bug 1756792 has been marked as a duplicate of this bug. ***

Comment 28 Eric Helms 2020-11-18 20:57:41 UTC
The katello-agent package, which provides our goferd integration, is designed around the Satellite workflows for registering a client with Satellite and using Satellite to manage it there after. The current workflows do not provide for us to disable this by default nor is there a benefit to current workflows. Given that, and the age of this BZ I am going to opt to close wontfix at this point.

If the original use case, or any new use cases require the need to have katello-agent (the part that handles remote yum actions only) to be present on a system but not registered to Satellite actively, please re-open and outline the use case.


Note You need to log in before you can comment on or make changes to this bug.