Bug 1576903 - Switch User menu item is missing
Summary: Switch User menu item is missing
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: accountsservice
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
Keywords: CommonBugs, Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 16:34 UTC by Steeve McCauley
Modified: 2019-01-21 15:00 UTC (History)
34 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-01-19 02:26:11 UTC


Attachments (Terms of Use)
Gnome Shell 3.28.1 User Menu without Switch User menu item (32.38 KB, image/jpeg)
2018-05-10 16:34 UTC, Steeve McCauley
no flags Details
Wanted config files (3.57 KB, application/zip)
2019-01-03 09:32 UTC, Марко М. Костић (Marko M. Kostić)
no flags Details

Description Steeve McCauley 2018-05-10 16:34:27 UTC
Created attachment 1434461 [details]
Gnome Shell 3.28.1 User Menu without Switch User menu item

Description of problem:

The gnome-shell Switch User menu item is missing from the (top right) User menu.

Version-Release number of selected component (if applicable):

$ gnome-shell --version
GNOME Shell 3.28.1


How reproducible:


Steps to Reproduce:
1. Click user menu
2. Click User name
3. 

Actual results:

Only Logout and Account settings menu items are there

Expected results:


Additional info:

This doesn't seem to happen on all of my systems.

Disabling all extensions and restarting the shell made no difference.

I am running gnome-shell on Xorg.

Comment 1 Johannes Pfau 2018-05-12 07:56:42 UTC
Same issue here on an upgraded F28 system (originally install was F25), reproducible with Xorg and Wayland.

To add some more information, IIRC there's some code which is supposed to detect if GDM is running and only display the "Switch User" entry if it is. There seems to be some problem with that code:
Whenever starting a new session from GDM, the "Switch User" entry is missing. But as soon as this session has once triggered the lockscreen (either timeout or manually locking the session) the "Switch User" entry becomes available. When then starting a new session for another user, the entry is missing again until that user/session triggers the lockscreen.

Comment 2 Steeve McCauley 2018-05-12 10:46:35 UTC
My system was also upgraded. But from F27 to F28 using dnf at the command line.

Can confirm that the Switch user entry appears after changing user from the lock screen, which might explain why I only saw it periodically.

I usually switch users with Ctrl+Alt+Fn, but my wife and kids tend to use the menu item.  For now, as a workaround, they switch back to the main GDM login with Ctrl+Alt+F1.

Comment 3 Michael Convey 2018-05-18 16:40:56 UTC
I too do not have "Switch User" menu item in Gnome in Fedora 28.

Comment 4 Michael Convey 2018-05-18 16:43:57 UTC
This issue has come up in the Fedora Forum here:
https://forums.fedoraforum.org/showthread.php?318138-No-quot-Switch-User-quot-in-Gnome-in-Fedora-28

Comment 5 Patrice Dehais 2018-05-23 20:13:19 UTC
Same problem of "Switch user" gone away after system upgrade from fed27 to fed28.

If I Install a fresh fed28 from ISO(*), the menu is there.
(*) Fedora release 28 (Twenty Eight)
Linux localhost.localdomain 4.16.3-301.fc28.x86_64 #1 SMP Mon Apr 23 21:59:58 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

I made the system update, and the menu is gone away.
Fedora release 28 (Twenty Eight)
Linux localhost.localdomain 4.16.9-300.fc28.x86_64 #1 SMP Thu May 17 06:39:18 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Comment 6 Steeve McCauley 2018-05-28 10:53:20 UTC
I've also seen the power button ⏻ missing on the top right menu.  Don't know if it is connected but something is wrong with this version of gnome (gdm?) when using multiple users.  authentication problems (logging back in), missing switch user, missing power button.  Still digging into it.

Comment 7 Ivo Petrov 2018-06-12 08:59:36 UTC
Maybe ralated, I'm also on F28 and am sometimes missing the switch user, however when it is there, clicking it sends me to the GDM and from there no matter how many times I type the correct password, login simply doesn't work - the only way to log back in is via Ctrl+Alt+F1/F2/F3 to find the actual login session of the user I want to use, the standard screen that the 'switch user' sends me to - doesn't work. If needed I can provide logs.

Comment 8 Steeve McCauley 2018-06-12 10:39:40 UTC
I've also abandoned any attempt to use gdm chooser for switch user authentication after the initial attempt, as it more often than not leads to the graphical system locking up (I can still ssh into the box remotely, but the mouse and screen freeze solid).

One consistent thing I've noticed when switching to the gdm chooser, the first click on one of the users in the list immediately results in "Authentication Error" message under the password control, without even entering a password, or hitting enter.

Comment 9 Cristián Rojas 2018-06-13 00:17:12 UTC
I'm having the same combind issue as Ivo in #7.

Comment 10 Morgan Timney 2018-07-02 19:47:25 UTC
My system was also upgraded. But from F27 to F28 using dnf at the command line.

Have same issue, and most of the time user switching simply does not work.

Comment 11 Steeve McCauley 2018-07-07 13:50:28 UTC
I installed a fresh install of Fedora 28 Workstation on a Boxes VM and can confirm that the issue exists in a fresh install as well.

Agreed with Cristián and Ivo (#7 and #9) that logging in from the GDM chooser doesn't work at all. The only way to login to another user session is using Ctrl+Alt+Fn and entering the screen saver password.  An initial login does work from the chooser, but after that you need to switch to the user session virtual screen.

A possibly related issue is this https://bugzilla.redhat.com/show_bug.cgi?id=1583240

Comment 12 Jeroen Verhoeckx 2018-07-27 23:15:04 UTC
I have exactly the same issue as described above:

* By default there is no Switch User item in the System menu.
* When I lock and unlock the screen the Switch User item does appear. 

Fedora: 28
GNOME: 3.28.3
Display server: Wayland
Window manager: Mutter 3.28.3
Display manager: GDM 3.28.2


Let me know if you need more information to solve this bug!

Comment 13 Solomon Peachy 2018-07-28 00:58:40 UTC
Also seeing this on a multi-user box that was upgraded from F27 to F28.  

Trying to log in as a different user from the lock screen forcibly kills existing sessions too.

Comment 14 Florian Müllner 2018-07-28 12:21:59 UTC
This was tracked down to a regression in AccountsService:
https://bugs.freedesktop.org/show_bug.cgi?id=107298

Comment 15 František Zatloukal 2018-09-20 09:16:27 UTC
This is still an issue in Fedora. I've reproduced this in Fedora 29 RC1.5 [0].

gnome-shell-3.30.0-7.fc29.x86_64
accountsservice-0.6.49-2.fc29.x86_64

Florian, can we get new accountsservice into Fedora? Thanks!

[0] https://fedoraproject.org/wiki/Test_Results:Fedora_29_Beta_1.5_Summary

Comment 16 Adam Williamson 2018-09-25 00:34:28 UTC
It seems there was an accountsservice 0.6.50 release, which...never got packaged.

I'll build it.

Comment 17 Adam Williamson 2018-09-25 01:05:42 UTC
*** Bug 1585036 has been marked as a duplicate of this bug. ***

Comment 18 Fedora Update System 2018-09-25 01:06:30 UTC
accountsservice-0.6.50-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-646c51188f

Comment 19 Adam Williamson 2018-09-25 01:07:00 UTC
The fix actually landed after 0.6.50 was released, so I built 0.6.50 with a backport of the fix.

Comment 20 Fedora Update System 2018-09-27 02:10:09 UTC
accountsservice-0.6.50-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-646c51188f

Comment 21 Fedora Update System 2018-09-29 22:01:55 UTC
accountsservice-0.6.50-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Марко М. Костић (Marko M. Kostić) 2018-10-03 15:14:38 UTC
I can still reproduce this issue with accountsservice-0.6.54-1.fc29. The software stack is:

Fedora: 29
GNOME: 3.30.1
Display server: Wayland
Window manager: Mutter 3.30.0
Display manager: GDM 3.30.1

The system was upgraded to 29 from Fedora 28 via the dnf system-upgrade plugin. The first user was originally setup by anaconda from the Fedora 28, the second and third users were added by `useradd` command. First and third user are using Gnome on Wayland while the second one is using Gnome on Xorg.

No option to switch user.

Comment 23 Tom Hughes 2018-10-18 16:00:13 UTC
I'm also seeing this since I upgraded to F29 with:

gnome-shell-3.30.1-1.fc29.x86_64
accountsservice-0.6.54-1.fc29.x86_64

Comment 24 Cristián Rojas 2018-11-02 01:08:09 UTC
Issue persists after upgrading Fedora from 28 to 29.

Comment 25 Daniel Rusek 2018-11-09 10:44:19 UTC
Still not fixed in Fedora 29.

Comment 26 Jeroen Verhoeckx 2018-11-09 12:01:09 UTC
The same for me: the Switch User menu is not visible in Fedora 29.
Let me know if you need more information.

Comment 27 Jim Mayer 2018-11-12 23:56:45 UTC
I upgraded the other day from Fedora 28, have installed all Fedora 29 updates, and see the same problem.

Comment 28 Alexey Brodkin 2018-11-17 09:21:10 UTC
Note here https://fedoraproject.org/wiki/Common_F29_bugs#switch-user-missing it is said that "Switch user" menu entry appears after the first time "Lock screen" gets displayed. But this is no longer the case for up to date Fedora 29.

And FWIW my "accountsservice" version:
------------------------->8----------------------
# dnf info accountsservice

Installed Packages
Name         : accountsservice
Version      : 0.6.54
Release      : 1.fc29
Arch         : x86_64
Size         : 351 k
Source       : accountsservice-0.6.54-1.fc29.src.rpm
Repo         : @System
From repo    : anaconda
Summary      : D-Bus interfaces for querying and manipulating user account information
URL          : https://www.freedesktop.org/wiki/Software/AccountsService/
License      : GPLv3+
Description  : The accountsservice project provides a set of D-Bus interfaces for
             : querying and manipulating user account information and an implementation
             : of these interfaces, based on the useradd, usermod and userdel commands.
------------------------->8----------------------

Also note the same situation is on both fresh install on F29 as well as on F28 upgraded to F29.

And that's really annoying as with that problem in place it's pretty inconvenient to use this machine by more than 1 person (which is not the problem typically for developers but some home users do use it that way).

Comment 29 Kamil Páral 2018-11-19 13:45:40 UTC
I added another workaround to the common bugs page. Nominating for a prioritized bug.

Comment 30 Steeve McCauley 2018-12-01 16:58:53 UTC
Confirming that the fix is still not in.  Upgraded to F29, ensured that the system was up to date, not even the work around works (locking the screen, with Super+L).

# rpm -qi "accountsservice"
Name        : accountsservice
Version     : 0.6.54
Release     : 1.fc29
Architecture: x86_64
Install Date: Sat 01 Dec 2018 09:57:51 AM EST
Group       : Unspecified
Size        : 359453
License     : GPLv3+
Signature   : RSA/SHA256, Sat 29 Sep 2018 09:11:43 AM EDT, Key ID a20aa56b429476b4
Source RPM  : accountsservice-0.6.54-1.fc29.src.rpm
Build Date  : Sat 29 Sep 2018 09:04:45 AM EDT
Build Host  : buildvm-21.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : https://www.freedesktop.org/wiki/Software/AccountsService/
Bug URL     : https://bugz.fedoraproject.org/accountsservice
Summary     : D-Bus interfaces for querying and manipulating user account information
Description :
The accountsservice project provides a set of D-Bus interfaces for
querying and manipulating user account information and an implementation
of these interfaces, based on the useradd, usermod and userdel commands.

Comment 31 Ben Cotton 2018-12-19 16:46:29 UTC
Accepted as a PrioritizedBug

Comment 32 Ray Strode [halfline] 2018-12-19 22:17:23 UTC
does screen lock make it spontaneously fix itself?

can those affected post output of $ getent passwd and output of all files in /var/lib/AccountsService ?

does booting in permissive mode fix it?

Comment 33 Марко М. Костић (Marko M. Kostić) 2019-01-03 09:31:32 UTC
Locking the screen and then unlocking it doesn't force the 'Swith User' option to appear in Gnome Shell.

The outputs are in the new bug attachment.

Booting the system with SELinux set in permissive mode does not fix the issue.

Comment 34 Марко М. Костић (Marko M. Kostić) 2019-01-03 09:32 UTC
Created attachment 1518114 [details]
Wanted config files

Comment 35 Elliott Sales de Andrade 2019-01-12 00:25:01 UTC
I tried to debug with a bit using the GI-Python interface:

> $ G_MESSAGES_DEBUG=all ipython3 
> In [1]: from gi.repository import AccountsService
>
> In [2]: um = AccountsService.UserManager.get_default()
>
> In [3]: um.can_switch()
> (process:7501): accountsservice-DEBUG: 19:21:47.558: ActUserManager: Unable to switch sessions until fully loaded
> Out[3]: False

The docs say it should load eventually, so running the GLib mainloop:

> In [4]: GLib.MainLoop().run()
> (process:7501): accountsservice-DEBUG: 19:21:53.530: ActUserManager: Seat still actively loading, so not setting loaded property
> (process:7501): accountsservice-DEBUG: 19:21:53.530: Failed to identify the current session: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ConsoleKit was not provided by any .service files
> (process:7501): accountsservice-DEBUG: 19:21:53.530: ActUserManager: seat unloaded, so trying to set loaded property
> (process:7501): accountsservice-DEBUG: 19:21:53.530: ActUserManager: Seat wouldn't load, so giving up on it and setting loaded property

Interrupting, then trying again:

> In [5]: um.can_switch()
> (process:7501): accountsservice-DEBUG: 19:23:14.184: ActUserManager: display seat ID is not set; can't switch sessions
> Out[5]: False


So why is it trying ConsoleKit; why can it not find the seat ID? I'm not sure yet how to debug further. There doesn't seem to be any output related to systemd.

Comment 36 Elliott Sales de Andrade 2019-01-12 00:36:39 UTC
On Fedora 28:

$ ldd /usr/lib64/libaccountsservice.so.0 | grep sys
        libsystemd.so.0 => /lib64/libsystemd.so.0 (...)

On Fedora 29:

$ ldd /usr/lib64/libaccountsservice.so.0 | grep sys
Nothing


So accountsservice is not built correctly against systemd; possibly a regression in the switch to meson.

Comment 37 Elliott Sales de Andrade 2019-01-12 04:05:39 UTC
The default systemd setting with autotools was 'auto'; the default with meson is disabled.

This PR enables systemd explicitly and fixes the menu for me:
https://src.fedoraproject.org/rpms/accountsservice/pull-request/3

Comment 38 Adam Williamson 2019-01-17 23:43:39 UTC
Thanks, Elliott - as the package got bumped in the meantime I manually re-did your changes and have sent out a -3 build for Rawhide, will do an update for F29 shortly.

Comment 39 Fedora Update System 2019-01-17 23:56:19 UTC
accountsservice-0.6.54-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-11de3c9a84

Comment 40 Fedora Update System 2019-01-18 03:36:31 UTC
accountsservice-0.6.54-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-11de3c9a84

Comment 41 Fedora Update System 2019-01-19 02:26:11 UTC
accountsservice-0.6.54-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 42 Марко М. Костић (Marko M. Kostić) 2019-01-19 09:49:46 UTC
I can confirm that the bug is resolved now on my system.

Comment 43 Steeve McCauley 2019-01-19 13:09:51 UTC
And just like that ... fixed.  Thanks.

Comment 44 Jeroen Verhoeckx 2019-01-21 14:07:27 UTC
Yes, the bug was fixed on my system too!
Thanks :-) !!

Comment 45 Daniel Rusek 2019-01-21 15:00:37 UTC
Fixed on my system as well. Thanks!


Note You need to log in before you can comment on or make changes to this bug.