Bug 1576911 - libboost_filesystem.so.1.64.0 missing ...
Summary: libboost_filesystem.so.1.64.0 missing ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: boost
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jonathan Wakely
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 16:50 UTC by Alberto
Modified: 2018-05-10 17:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 17:17:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Alberto 2018-05-10 16:50:02 UTC
Description of problem: Nothing provides libboost_filesystem.so.1.64.0


Version-Release number of selected component (if applicable): Fedora 28


How reproducible: Trying to install the epson scanning program imagescan-bundle-fedora-27-1.3.28.x86.rpm (this program is not available for Fedora 28 yet but should work all the same)


Steps to Reproduce:
1.You install it by means of install.sh
2.
3.

Actual results: conflicting requests: nothing provides libboost_filesystem.so.1.64.0 needed by imagescan-3.38.0-1 epson4fedora27.i686


Expected results:the right istallation of the scanning driver for my Epson XP-540 all-in-one


Additional info:this bug is similar to the bug 1575767 that I found here

Comment 1 Jonathan Wakely 2018-05-10 17:17:32 UTC
(In reply to Alberto from comment #0)
> How reproducible: Trying to install the epson scanning program
> imagescan-bundle-fedora-27-1.3.28.x86.rpm (this program is not available for
> Fedora 28 yet but should work all the same)

No it shouldn't, because Fedora 28 has a different version of Boost.

This is not a bug, Fedora 28 has libboost_filesystem.so.1.66.0 so you need a new version of the scanning program that is compatible with F28.

Comment 2 Jonathan Wakely 2018-05-10 17:19:11 UTC
(In reply to Alberto from comment #0)
> Additional info:this bug is similar to the bug 1575767 that I found here

Which is also not a bug in Boost, it's a bug in LuxRender because it needs to be updated to be compatible with F28.


Note You need to log in before you can comment on or make changes to this bug.