Bug 1577162 - gfapi: broken symbol versions
Summary: gfapi: broken symbol versions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1575716
Blocks: 1577163 1577164
TreeView+ depends on / blocked
 
Reported: 2018-05-11 11:18 UTC by Kaleb KEITHLEY
Modified: 2018-06-20 18:06 UTC (History)
1 user (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1575716
: 1577163 (view as bug list)
Environment:
Last Closed: 2018-06-20 18:06:01 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2018-05-11 11:18:17 UTC
+++ This bug was initially created as a clone of Bug #1575716 +++

Description of problem:

glfs_upcall_register(), glfs_upcall_unregister(), and glfs_h_poll_upcall did not follow the guidelines, broke build on FreeBSD 11, potential obscure bugs on Linux.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2018-05-07 14:58:47 EDT ---

REVIEW: https://review.gluster.org/19974 (gfapi: various broken symbol versions) posted (#1) for review on master by Kaleb KEITHLEY

--- Additional comment from Worker Ant on 2018-05-10 17:43:41 EDT ---

COMMIT: https://review.gluster.org/19974 committed in master by "Kaleb KEITHLEY" <kkeithle@redhat.com> with a commit message- gfapi: various broken symbol versions

lots of breakage in symbol versions:
  symbols added in 4.1 incorrectly, and
  symbols added in 4.1 but labeled 4.0.0, and
  symbols added in 3.13 incorrectly

Not noticed until someone tried to build 3.13.2 on FreeBSD 11.1,
despite the fact that we build on FreeBSD 10.3 IIRC, somehow the
3.13 errors aren't a build error there.

Note: in rereading the Ulrich Drepper write-up I noticed that when
a symbol version is changed, you are supposed to leave the old
symbol in its original section in addition to adding it to its new
section. Adding back those symbols to their original sections.

Reported-by: Roman Serbski <mefystofel@gmail.com>

Change-Id: I9a883546d08e0847f7228d8ea5943bc54275b319
fixes: bz#1575716
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>

Comment 1 Worker Ant 2018-05-11 15:22:10 UTC
REVIEW: https://review.gluster.org/20010 (gfapi: various broken symbol versions) posted (#1) for review on release-4.1 by Kaleb KEITHLEY

Comment 2 Worker Ant 2018-05-15 13:54:06 UTC
COMMIT: https://review.gluster.org/20010 committed in release-4.1 by "Kaleb KEITHLEY" <kkeithle@redhat.com> with a commit message- gfapi: various broken symbol versions

lots of breakage in symbol versions:
  symbols added in 4.1 incorrectly, and
  symbols added in 4.1 but labeled 4.0.0, and
  symbols added in 3.13 incorrectly

Not noticed until someone tried to build 3.13.2 on FreeBSD 11.1,
despite the fact that we build on FreeBSD 10.3 IIRC, somehow the
3.13 errors aren't a build error there.

Note: in rereading the Ulrich Drepper write-up I noticed that when
a symbol version is changed, you are supposed to leave the old
symbol in its original section in addition to adding it to its new
section. Adding back those symbols to their original sections.

Reported-by: Roman Serbski <mefystofel@gmail.com>

Change-Id: I9a883546d08e0847f7228d8ea5943bc54275b319
fixes: bz#1577162
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>

Comment 3 Shyamsundar 2018-06-20 18:06:01 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.