Bug 1577186 - The "bat" program has been replaced by some kind of build script.
Summary: The "bat" program has been replaced by some kind of build script.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bacula
Version: 28
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Simone Caronni
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1578090 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 12:18 UTC by Paul Johnson
Modified: 2018-06-07 17:20 UTC (History)
6 users (show)

Fixed In Version: bacula-9.0.7-2.fc27 bacula-9.0.7-3.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-06 12:57:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Paul Johnson 2018-05-11 12:18:53 UTC
Description of problem:

The package "bacula-console-bat-9.0.6-8.fc28.x86_64" installs a shell script as /usr/sbin/bat which seems to be part of the build system.

Version-Release number of selected component (if applicable):

9.0.6-8

How reproducible:

Always.


Steps to Reproduce:
1. dnf install bacula-console-bat
2. bat


Actual results:

/usr/sbin/bat: line 202: cd: /builddir/build/BUILD/bacula-9.0.6/src/qt-console: No such file or directory
/usr/sbin/bat: line 202: g++: command not foundn


Expected results:

The "bat" GUI should be displayed.

Additional info:

The script comments say it was generated by GNU libtool and should not be moved out of the build directory.

Comment 1 Fedora Update System 2018-05-14 11:40:30 UTC
bacula-9.0.7-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ee062a47e4

Comment 2 Fedora Update System 2018-05-14 11:40:48 UTC
bacula-9.0.7-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b6baf2517b

Comment 3 Fedora Update System 2018-05-14 19:17:13 UTC
bacula-9.0.7-2.fc27, bacula-docs-9.0.7-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ee062a47e4

Comment 4 Fedora Update System 2018-05-14 20:39:39 UTC
bacula-9.0.7-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b6baf2517b

Comment 5 Simone Caronni 2018-05-16 12:05:31 UTC
*** Bug 1578090 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2018-06-06 12:57:42 UTC
bacula-9.0.7-2.fc27, bacula-docs-9.0.7-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2018-06-06 13:30:03 UTC
bacula-9.0.7-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Paul Johnson 2018-06-07 17:20:26 UTC
I can't upgrade to bacula-9.0.7. I've reported this as a new bug here:
https://bugzilla.redhat.com/show_bug.cgi?id=1588668


Note You need to log in before you can comment on or make changes to this bug.