Bug 1577205 - Null pointer exception with getting advanced brick details
Summary: Null pointer exception with getting advanced brick details
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhi-1.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHHI-V 1.5
Assignee: Sahina Bose
QA Contact: bipin
URL:
Whiteboard:
Depends On: 1577208
Blocks: 1520836
TreeView+ depends on / blocked
 
Reported: 2018-05-11 13:09 UTC by SATHEESARAN
Modified: 2018-11-08 05:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1577208 (view as bug list)
Environment:
Last Closed: 2018-11-08 05:39:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3523 0 None None None 2018-11-08 05:39:53 UTC

Description SATHEESARAN 2018-05-11 13:09:21 UTC
Description of problem:
-----------------------
While obtaining the advanced brick details, observed a consistent null pointer exception ( NPE )

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHV 4.2.3-6
RHGS 3.3.1 (glusterfs-3.8.4-54.8.el7rhgs)/RHGS 3.4.0 nightly (glusterfs-3.12.2-8.el7rhgs )

How reproducible:
-----------------
always

Steps to Reproduce:
---------------------
1. Deploy 3 node hyperconverged setup with RHV & RHGS
2. Click the volume and select the volume, select the brick of the volume
3. Get the advanced brick details

Actual results:
---------------
1. Unable to get the advanced bricks details
2. Null pointer exception in the engine.log

Expected results:
-----------------
Advanced brick details should be obtained


Additional info:

Comment 4 bipin 2018-06-19 11:09:14 UTC
Verified the bug on RHV 4.2.4.5 could see the functionality working.

Adding the screenshot of the verfied bug.

Comment 8 errata-xmlrpc 2018-11-08 05:39:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3523


Note You need to log in before you can comment on or make changes to this bug.