Bug 1577208 - Null pointer exception with getting advanced brick details
Summary: Null pointer exception with getting advanced brick details
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.3.5
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ovirt-4.2.4
: ---
Assignee: Denis Chaplygin
QA Contact: bipin
URL:
Whiteboard:
Depends On:
Blocks: 1577205
TreeView+ depends on / blocked
 
Reported: 2018-05-11 13:11 UTC by SATHEESARAN
Modified: 2018-06-26 08:34 UTC (History)
6 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of: 1577205
Environment:
Last Closed: 2018-06-26 08:34:12 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.2?
bshetty: planning_ack?
rule-engine: devel_ack+
bshetty: testing_ack+


Attachments (Terms of Use)
Screenshot of advanced brick details (20.49 KB, image/png)
2018-05-11 13:18 UTC, SATHEESARAN
no flags Details
snip of engine log (36.83 KB, text/plain)
2018-05-11 13:19 UTC, SATHEESARAN
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90905 0 None None None 2018-05-21 09:19:35 UTC

Description SATHEESARAN 2018-05-11 13:11:51 UTC
Description of problem:
-----------------------
While obtaining the advanced brick details, observed a consistent null pointer exception ( NPE )

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
oVirt 4.2.3
glusterfs-3.12.2-8.el7rhgs

How reproducible:
-----------------
always

Steps to Reproduce:
---------------------
1. Deploy 3 node hyperconverged setup with oVirt & gluster
2. Click the volume and select the volume, select the brick of the volume
3. Get the advanced brick details

Actual results:
---------------
1. Unable to get the advanced bricks details
2. Null pointer exception in the engine.log

Expected results:
-----------------
Advanced brick details should be obtained

Comment 1 SATHEESARAN 2018-05-11 13:18:47 UTC
Created attachment 1434900 [details]
Screenshot of advanced brick details

Screenshot showing the advanced brick details

Comment 2 SATHEESARAN 2018-05-11 13:19:39 UTC
Created attachment 1434901 [details]
snip of engine log

snippet of engine log showing the null pointer exception.

Comment 3 Sahina Bose 2018-05-14 07:11:47 UTC
Denis, can you please check if this is related to your patch?

Comment 4 Denis Chaplygin 2018-05-17 09:08:21 UTC
(In reply to Sahina Bose from comment #3)
> Denis, can you please check if this is related to your patch?

Yes. Fixed with https://gerrit.ovirt.org/90905/

Comment 5 Sandro Bonazzola 2018-05-25 07:58:49 UTC
Referenced patch is included in ovirt-engine-4.2.4, moving to qe

Comment 6 bipin 2018-06-19 10:51:05 UTC
Verified the bug on RHV 4.2.4.5 could see the functionality working.

Adding the screenshot of the verfied bug.

Comment 9 Sandro Bonazzola 2018-06-26 08:34:12 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.