Bug 1577236 - [RFE][TechPreview] Low-footprint installation of OpenStack (aka all-in-one) w/o management node
Summary: [RFE][TechPreview] Low-footprint installation of OpenStack (aka all-in-one) w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 14.0 (Rocky)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: beta
: 14.0 (Rocky)
Assignee: Alex Schultz
QA Contact: Artem Hrechanychenko
URL:
Whiteboard:
: 1519571 (view as bug list)
Depends On:
Blocks: 1476900 1623941 1615697
TreeView+ depends on / blocked
 
Reported: 2018-05-11 14:14 UTC by Alex Schultz
Modified: 2019-01-11 11:50 UTC (History)
15 users (show)

Fixed In Version: python-tripleoclient-10.2.1-0.20180709114814.e5ce9a8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-11 11:49:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:0045 None None None 2019-01-11 11:50:35 UTC

Description Alex Schultz 2018-05-11 14:14:30 UTC
To assist with Development and CI related work, it would be beneficial to have a single node all-in-one installation method that utilizes TripleO to deploy OpenStack and related services.  The goal would be to enable PoC deployments on a single node with limited (or no) day 2 operations.

Benefits:
* composable services (any set of services)
* can create a set of pre-defined roles to make it easy for devs
* a condensed single node environment.
* lower bar to be able to dev/test TripleO. Single machine: VM. Simpler tooling
* alternate interface (playbooks) could allow users to run the installer itself in a container. Small footprint installer. Container -> generates Ansible playbooks. Which you launch on a host.

Comment 1 Alex Schultz 2018-05-11 14:15:57 UTC
Related upstream blueprint https://blueprints.launchpad.net/tripleo/+spec/all-in-one

Comment 10 Mike Burns 2018-07-13 18:39:48 UTC
*** Bug 1519571 has been marked as a duplicate of this bug. ***

Comment 18 errata-xmlrpc 2019-01-11 11:49:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.