Bug 1577277 - Firefox 60 crashes when opening new window/tab
Summary: Firefox 60 crashes when opening new window/tab
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: 28
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1577607 1579939 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 15:10 UTC by Marc Muehlfeld
Modified: 2018-05-30 14:32 UTC (History)
24 users (show)

Fixed In Version: firefox-60.0.1-3.fc28 firefox-60.0.1-3.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-05-29 11:21:03 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (50.20 KB, image/png)
2018-05-11 15:10 UTC, Marc Muehlfeld
no flags Details
Stack trace with debug symbols (5.21 KB, text/plain)
2018-05-16 00:23 UTC, James Clark
no flags Details

Description Marc Muehlfeld 2018-05-11 15:10:05 UTC
Created attachment 1435015 [details]
screenshot

Description of problem:
After upgrading to Firefox 60, very often when I open a new window or tab in Firefox, this window or tab crashes. This also continued after I created a new Firefox profile.


Version-Release number of selected component (if applicable):
firefox-60.0-4.fc28.x86_64


How reproducible:
Sporadically.
Sometimes it happens 5-10 times in a row, sometimes I can open >20 new tabs or windows without a crash.


Steps to Reproduce:
1. Use Firefox 60
2. Open a new tab or Firefox window


Actual results:
Window/tab crashes


Expected results:
Window/tab should not crash.


Additional info:
In /var/log/messages, the crashes are logged:
May 11 16:50:51 PC systemd-coredump[12682]: Process 12674 (Web Content) of user 1000 dumped core.#012#012Stack trace of thread 12677:#012#0  0x00005623e71454b2 _Z14mozalloc_abortPKc (firefox)#012#1  0x00005623e71397b6 abort (firefox)#012#2  0x00007f166a717888 n/a (libxul.so)#012#3  0x00007f166abd1284 n/a (libxul.so)#012#4  0x00007f166abd1d51 n/a (libxul.so)#012#5  0x00007f166abd886a n/a (libxul.so)#012#6  0x00007f166abd8e7f n/a (libxul.so)#012#7  0x00007f166abbe4ce n/a (libxul.so)#012#8  0x00007f166abc0959 n/a (libxul.so)#012#9  0x00007f166abce875 n/a (libxul.so)#012#10 0x00007f166abbdfee n/a (libxul.so)#012#11 0x00007f167b419564 start_thread (libpthread.so.0)#012#12 0x00007f167a60b31f __clone (libc.so.6)#012#012Stack trace of thread 12674:#012#0  0x00007f166a73436d n/a (libxul.so)#012#1  0x00007f166a7c775d n/a (libxul.so)#012#2  0x00007f166a7a2443 n/a (libxul.so)#012#3  0x00007f166a7a3fdf n/a (libxul.so)#012#4  0x00007f166a7a4257 n/a (libxul.so)#012#5  0x00007f166a7a42be n/a (libxul.so)#012#6  0x00007f166a7a3fdf n/a (libxul.so)#012#7  0x00007f166a7a4257 n/a (libxul.so)#012#8  0x00007f166a7a4337 n/a (libxul.so)#012#9  0x00007f166a7a519b n/a (libxul.so)#012#10 0x00007f166a7d9081 n/a (libxul.so)#012#11 0x00007f166d5a2388 n/a (libxul.so)#012#12 0x00007f166abf24e2 n/a (libxul.so)#012#13 0x00007f166c47df83 n/a (libxul.so)#012#14 0x00007f166d5a28e0 n/a (libxul.so)#012#15 0x00005623e713a3ba n/a (firefox)#012#16 0x00005623e7139d24 n/a (firefox)#012#17 0x00007f167a5341bb __libc_start_main (libc.so.6)#012#18 0x00005623e7139fda _start (firefox)#012#012Stack trace of thread 12678:#012#0  0x00007f167a600929 __poll (libc.so.6)#012#1  0x00007f1675df0b06 g_main_context_iterate.isra.21 (libglib-2.0.so.0)#012#2  0x00007f1675df0c30 g_main_context_iteration (libglib-2.0.so.0)#012#3  0x00007f1675df0c81 glib_worker_main (libglib-2.0.so.0)#012#4  0x00007f1675e18cea g_thread_proxy (libglib-2.0.so.0)#012#5  0x00007f167b419564 start_thread (libpthread.so.0)#012#6  0x00007f167a60b31f __clone (libc.so.6)#012#012Stack trace of thread 12679:#012#0  0x00007f167a600929 __poll (libc.so.6)#012#1  0x00007f1675df0b06 g_main_context_iterate.isra.21 (libglib-2.0.so.0)#012#2  0x00007f1675df0ec2 g_main_loop_run (libglib-2.0.so.0)#012#3  0x00007f16763e060a gdbus_shared_thread_func (libgio-2.0.so.0)#012#4  0x00007f1675e18cea g_thread_proxy (libglib-2.0.so.0)#012#5  0x00007f167b419564 start_thread (libpthread.so.0)#012#6  0x00007f167a60b31f __clone (libc.so.6)
May 11 16:50:51 PC audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-coredump@46-12681-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Unfortunately, I don't know if and where the core dumps are stored.

Comment 1 Martin Stransky 2018-05-14 12:04:21 UTC
Do you see any crashes at about:crashes ?

Comment 3 Martin Stransky 2018-05-15 11:37:14 UTC
I see a recent regression at Addon handling. Can you please try to create a new fresh profile ($firefox -ProfileManager) and also disable all extensions in the new profile? Also do you see any related messages (selinux, mozilla sandbox) at system log ($journalctl -b). Thanks!

Comment 4 Martin Stransky 2018-05-15 11:40:56 UTC
Also, can you please download and try stock Firefox versions from mozilla.com? 
Also please test Beta/Developer edition (https://www.mozilla.org/en-US/firefox/channel/desktop/).

Comment 5 Marc Muehlfeld 2018-05-15 15:43:47 UTC
(In reply to Martin Stransky from comment #3)
> I see a recent regression at Addon handling. Can you please try to create a
> new fresh profile ($firefox -ProfileManager) and also disable all extensions
> in the new profile? Also do you see any related messages (selinux, mozilla
> sandbox) at system log ($journalctl -b). Thanks!

I tried it with a fresh profile and without any add-ons. It seems to work.

Then I installed uBlock Origin and soon the crashes were back.

I uninstalled the add-on and installed HTTPS Everywhere. With only this add-on installed, it also seems to work.

The above I tested with the packages from F28.

However, this seems to not only be a problem with this add-on. I use FF60 and F28 on my home computer with the same two add-ons. I had no crash on my desktop; only on my work laptop.


I will test it tomorrow with the stock versions.

Comment 6 James Clark 2018-05-16 00:23 UTC
Created attachment 1437025 [details]
Stack trace with debug symbols

I created a new profile using "firefox -ProfileManager" and managed to repeat the crash. There were no extensions, but the "English (GB) Language Pack" version 60.buildid20180503143129 was enabled. I disabled this and I couldn't reproduce the crash anymore.

I also couldn't reproduce the crash with the binary of Firefox 60 from Mozilla directly.

I don't see any related messages from "journalctl -b" except the stack trace

If it helps, I've attached the stack trace with (demangled) debug symbols.

Comment 7 Marc Muehlfeld 2018-05-16 06:55:17 UTC
I have to withdraw #c5. FF60 (F28 packages) even crashes with a new profile an no add-ons installed.

In #c6, the language pack came into play. I only have installed:
> Deutsch (DE) Language Pack 60.0buildid20180503143129

Comment 8 Sebastian 2018-05-16 14:55:31 UTC
Same issue here...

$ journalctl | grep firefox

Mai 16 16:32:47 localhost.localdomain audit[20424]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=20424 comm="Chrome_~dThread" exe="/usr/lib64/firefox/firefox" sig=11 res=1
Mai 16 16:32:47 localhost.localdomain kernel: Chrome_~dThread[20428]: segfault at 0 ip 000055f79bcce4b2 sp 00007f2ce69179e0 error 6 in firefox[55f79bcbd000+31000]
Mai 16 16:32:47 localhost.localdomain keepass.desktop[13003]: [Parent 13094, Gecko_IOThread] WARNING: pipe error (99): Connection reset by peer: file /builddir/build/BUILD/firefox-60.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
Mai 16 16:32:47 localhost.localdomain keepass.desktop[13003]: [Parent 13094, Gecko_IOThread] WARNING: pipe error (169): Connection reset by peer: file /builddir/build/BUILD/firefox-60.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
Mai 16 16:32:47 localhost.localdomain keepass.desktop[13003]: [Parent 13094, Gecko_IOThread] WARNING: pipe error (157): Connection reset by peer: file /builddir/build/BUILD/firefox-60.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
Mai 16 16:32:47 localhost.localdomain keepass.desktop[13003]: [Parent 13094, Gecko_IOThread] WARNING: pipe error (135): Connection reset by peer: file /builddir/build/BUILD/firefox-60.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
Mai 16 16:32:47 localhost.localdomain keepass.desktop[13003]: [Parent 13094, Gecko_IOThread] WARNING: pipe error (141): Connection reset by peer: file /builddir/build/BUILD/firefox-60.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
Mai 16 16:32:47 localhost.localdomain keepass.desktop[13003]: [Parent 13094, Gecko_IOThread] WARNING: pipe error (147): Connection reset by peer: file /builddir/build/BUILD/firefox-60.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
                                                               #0  0x000055f79bcce4b2 _Z14mozalloc_abortPKc (firefox)
                                                               #1  0x000055f79bcc27b6 abort (firefox)
                                                               #33 0x000055f79bcc33ba n/a (firefox)
                                                               #34 0x000055f79bcc2d24 n/a (firefox)
                                                               #36 0x000055f79bcc2fda _start (firefox)
Mai 16 16:32:48 localhost.localdomain abrt-notification[20492]: Process 4805 (firefox) crashed in mozalloc_abort(char const*)()


about:crashes
https://crash-stats.mozilla.com/report/index/72737b48-72dc-43eb-8d62-cd4e10180516

Comment 9 Marc Muehlfeld 2018-05-16 15:52:10 UTC
Currently, it looks like the problem exists only in the F28 package here (with and without add-ons installed).

Today I used 4h FF60 from upstream without any add-ons installed and no crash appeared.

Then I used 3h FF60 from upstream with uBlock and HTTPS everywhere installed and also no crash.

Please let me know if I can provide further details or test something.

Comment 10 Konstantin Zaytsev 2018-05-17 14:36:26 UTC
Have same problem even with clean profile

Example of crash report
https://crash-stats.mozilla.com/report/index/c1cb20bf-5a4e-4dca-9ec0-d7cbc0180517

Comment 11 Martin Stransky 2018-05-17 19:01:41 UTC
All those crashes unfortunately comes from content (e10s) process. Can you please try to disable e10s (set browser.tabs.remote.autostart to false at about:config) and try that? If you see the crash without e10s it will be useful to see a backtrace. Thanks.

Comment 12 Martin Stransky 2018-05-18 07:27:43 UTC
All those are null pointer crashes, looks like kind of assertion or missing system resources (file descriptors for instance) for IPC/e10s. It may be related to https://bugzilla.mozilla.org/show_bug.cgi?id=1401776

Comment 13 Marc Muehlfeld 2018-05-18 12:10:54 UTC
Firefox 60 packages from Fedora 28 with browser.tabs.remote.autostart=false:
No crash since setting this to "false" (was 4.5h ago)

Comment 14 Sebastian 2018-05-18 12:42:57 UTC
Setting "browser.tabs.remote.autostart" to "false" did it for me as well. Thank you.
(Firefox 60.0, up to date Fedora 28)

Comment 15 AsciiWolf 2018-05-18 17:38:36 UTC
I am experiencing the same issue with Firefox 60 on Fedora 28.

Comment 16 Christian Stadelmann 2018-05-19 09:43:07 UTC
(In reply to Martin Stransky from comment #11)
> All those crashes unfortunately comes from content (e10s) process. Can you
> please try to disable e10s (set browser.tabs.remote.autostart to false at
> about:config) and try that? If you see the crash without e10s it will be
> useful to see a backtrace. Thanks.

With browser.tabs.remote.autostart=true (the default), I'm also running into this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1579939
With browser.tabs.remote.autostart=false, firefox does not crash any more.

Comment 17 Christian Stadelmann 2018-05-21 09:26:23 UTC
(In reply to Christian Stadelmann from comment #16)
> (In reply to Martin Stransky from comment #11)
> > All those crashes unfortunately comes from content (e10s) process. Can you
> > please try to disable e10s (set browser.tabs.remote.autostart to false at
> > about:config) and try that? If you see the crash without e10s it will be
> > useful to see a backtrace. Thanks.
> 
> With browser.tabs.remote.autostart=true (the default), I'm also running into
> this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1579939
> With browser.tabs.remote.autostart=false, firefox does not crash any more.

I was wrong about that. With browser.tabs.remote.autostart=false, I still get crashes all the time, but they are not visible any more i.e. they do no longer interfere with using firefox.

Here is the link to one:
https://crash-stats.mozilla.com/report/index/28a5fd17-9335-43b7-9939-8677f0180521

abrt/libreport tells me this bug has the backtrace reported https://bugzilla.redhat.com/show_bug.cgi?id=1579939 which seems wrong to me since it looks like a content process backtrace.

There is an upstream bug report with a similar backtrace, https://bugzilla.mozilla.org/show_bug.cgi?id=1436242, which may help finding a solution.

Comment 18 Christian Stadelmann 2018-05-21 19:08:28 UTC
The upstream bug report https://bugzilla.mozilla.org/show_bug.cgi?id=1436242 has an explanation why this happens and a link to a fix in chromium: https://github.com/chromium/chromium/commit/334f302db0310f47d20eb532cb0bae401a0eddbe. Upstream is working on this.

Comment 20 Jed Davis 2018-05-24 21:55:04 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1579939 appears to be a duplicate of this.

If I understand correctly this is causing crashes in Fedora's builds but not Mozilla's builds, because you're enabling assertions in libstdc++ that detect the undefined behavior (which is otherwise more or less harmless in practice) and that's all handled in header files.

The Firefox bug has been marked wontfix for 60 (and given that it doesn't affect our builds, I don't know that I could convince release management otherwise), so you'll need to apply https://hg.mozilla.org/mozilla-central/rev/6bb3adfa15c6 locally to Fedora's packages.

Comment 21 Martin Stransky 2018-05-25 13:17:19 UTC
(In reply to Jed Davis from comment #20)
> The Firefox bug has been marked wontfix for 60 (and given that it doesn't
> affect our builds, I don't know that I could convince release management
> otherwise), so you'll need to apply
> https://hg.mozilla.org/mozilla-central/rev/6bb3adfa15c6 locally to Fedora's
> packages.

I'll apply that locally, Thanks.

Comment 22 Fedora Update System 2018-05-28 08:07:47 UTC
firefox-60.0.1-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a62434cca8

Comment 23 Fedora Update System 2018-05-28 08:08:01 UTC
firefox-60.0.1-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1f788d5c09

Comment 24 Fedora Update System 2018-05-28 08:08:14 UTC
firefox-60.0.1-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c0674d672f

Comment 25 Christian Stadelmann 2018-05-28 08:39:27 UTC
*** Bug 1579939 has been marked as a duplicate of this bug. ***

Comment 26 Martin Stransky 2018-05-28 11:09:44 UTC
*** Bug 1577607 has been marked as a duplicate of this bug. ***

Comment 27 Fedora Update System 2018-05-28 14:25:02 UTC
firefox-60.0.1-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a62434cca8

Comment 28 Fedora Update System 2018-05-28 14:28:09 UTC
firefox-60.0.1-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1f788d5c09

Comment 29 Fedora Update System 2018-05-28 15:49:18 UTC
firefox-60.0.1-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c0674d672f

Comment 30 Fedora Update System 2018-05-29 11:21:03 UTC
firefox-60.0.1-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 31 Fedora Update System 2018-05-30 14:32:31 UTC
firefox-60.0.1-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.