Bug 1577607 - segfaults - lots of crashes; matches a few heavy fafreports
Summary: segfaults - lots of crashes; matches a few heavy fafreports
Keywords:
Status: CLOSED DUPLICATE of bug 1577277
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-13 12:41 UTC by Dr. David Alan Gilbert
Modified: 2018-05-28 11:09 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-28 11:09:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Dr. David Alan Gilbert 2018-05-13 12:41:27 UTC
Description of problem:
Updated my f28 to firefox 60 today and it's not lasting more than a minute or two before segfaulting in a variety of places; the fafreports abrt is showing show lots of people hitting it in the last few days:
https://retrace.fedoraproject.org/faf/reports/2159933/
https://retrace.fedoraproject.org/faf/reports/2161610/

Version-Release number of selected component (if applicable):
60.0-4.fc28

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Dr. David Alan Gilbert 2018-05-14 16:24:26 UTC
Same thing happens on my work machine; entirely different hardware.

Comment 2 Martin Stransky 2018-05-15 11:43:43 UTC
That may be a dupe of Bug 1577277.

Can you please try to create a new fresh profile ($firefox -ProfileManager) and also disable all extensions in the new profile? Also do you see any related messages (selinux, mozilla sandbox) at system log ($journalctl -b). Thanks!

Also do you see any crashes at about:crash? If so please attach the signatures here.

Comment 3 Dr. David Alan Gilbert 2018-05-16 17:49:15 UTC
(In reply to Martin Stransky from comment #2)
> That may be a dupe of Bug 1577277.
> 
> Can you please try to create a new fresh profile ($firefox -ProfileManager)
> and also disable all extensions in the new profile? Also do you see any
> related messages (selinux, mozilla sandbox) at system log ($journalctl -b).
> Thanks!

I'm not seeing anything in the journal except the crash.  The odd thing is while it was failing like mad on Sunday (home machine) and Monday (work machine) - not surviving even for a few pages; now I've rolled them forward again to 60 from 59 (that I'd rolled back to) they seem happy on both of them; even on the existing profiles. So - wth?

> Also do you see any crashes at about:crash? If so please attach the
> signatures here.

Home machine:
https://crash-stats.mozilla.com/report/index/ea54dee7-2ea9-4bc5-b356-564191180513
https://crash-stats.mozilla.com/report/index/a0ad7440-188c-47a2-871d-5debd1180513

Comment 4 Martin Stransky 2018-05-18 07:26:50 UTC
(In reply to Dr. David Alan Gilbert from comment #3)
> (In reply to Martin Stransky from comment #2)
> > That may be a dupe of Bug 1577277.
> > 
> > Can you please try to create a new fresh profile ($firefox -ProfileManager)
> > and also disable all extensions in the new profile? Also do you see any
> > related messages (selinux, mozilla sandbox) at system log ($journalctl -b).
> > Thanks!
> 
> I'm not seeing anything in the journal except the crash.  The odd thing is
> while it was failing like mad on Sunday (home machine) and Monday (work
> machine) - not surviving even for a few pages; now I've rolled them forward
> again to 60 from 59 (that I'd rolled back to) they seem happy on both of
> them; even on the existing profiles. So - wth?
> 
> > Also do you see any crashes at about:crash? If so please attach the
> > signatures here.
> 
> Home machine:
> https://crash-stats.mozilla.com/report/index/ea54dee7-2ea9-4bc5-b356-
> 564191180513
> https://crash-stats.mozilla.com/report/index/a0ad7440-188c-47a2-871d-
> 5debd1180513

Well, all those are null pointer crashes, looks like kind of assertion or missing system resources (file descriptors for instance) for IPC/e10s. There's similar bugreport here (Bug 1577277) and may be related to https://bugzilla.mozilla.org/show_bug.cgi?id=1401776

IF you see the crash again please try steps from https://bugzilla.redhat.com/show_bug.cgi?id=1577277#c11, Thanks.

Comment 5 Dr. David Alan Gilbert 2018-05-19 11:48:07 UTC
(In reply to Martin Stransky from comment #4)
> (In reply to Dr. David Alan Gilbert from comment #3)
> > (In reply to Martin Stransky from comment #2)
> > > That may be a dupe of Bug 1577277.
> > > 
> > > Can you please try to create a new fresh profile ($firefox -ProfileManager)
> > > and also disable all extensions in the new profile? Also do you see any
> > > related messages (selinux, mozilla sandbox) at system log ($journalctl -b).
> > > Thanks!
> > 
> > I'm not seeing anything in the journal except the crash.  The odd thing is
> > while it was failing like mad on Sunday (home machine) and Monday (work
> > machine) - not surviving even for a few pages; now I've rolled them forward
> > again to 60 from 59 (that I'd rolled back to) they seem happy on both of
> > them; even on the existing profiles. So - wth?
> > 
> > > Also do you see any crashes at about:crash? If so please attach the
> > > signatures here.
> > 
> > Home machine:
> > https://crash-stats.mozilla.com/report/index/ea54dee7-2ea9-4bc5-b356-
> > 564191180513
> > https://crash-stats.mozilla.com/report/index/a0ad7440-188c-47a2-871d-
> > 5debd1180513
> 
> Well, all those are null pointer crashes, looks like kind of assertion or
> missing system resources (file descriptors for instance) for IPC/e10s.
> There's similar bugreport here (Bug 1577277) and may be related to
> https://bugzilla.mozilla.org/show_bug.cgi?id=1401776
> 
> IF you see the crash again please try steps from
> https://bugzilla.redhat.com/show_bug.cgi?id=1577277#c11, Thanks.

and while I had none yesterday; I just got:
https://crash-stats.mozilla.com/report/index/4221d658-c418-4554-bfdb-faaf21180519

and remote.autostart=false seems to be helping, I'll keep an eye on it

Comment 6 Dr. David Alan Gilbert 2018-05-19 20:20:49 UTC
That was working well for a while then I started getting some more crashes; I've now set remote.autostart.2=false as well and that seems to be helping more; latest crashes:

https://crash-stats.mozilla.com/report/index/4b7ded8a-ec35-49be-b2e0-5d0d81180519
https://crash-stats.mozilla.com/report/index/ba90c2c0-a41e-4328-9f0f-5b10c1180519

Comment 7 Dr. David Alan Gilbert 2018-05-19 20:25:49 UTC
hmm no, still doing it:
https://crash-stats.mozilla.com/report/index/d9063795-ad9e-4a7b-92b6-b56ac1180519

time to go back to 59

Comment 8 Martin Stransky 2018-05-28 11:09:44 UTC
Perhaps a dupe of Bug 1577277 - please reopen if the new update [1] does not help you.

[1] https://bodhi.fedoraproject.org/updates/FEDORA-2018-c0674d672f

*** This bug has been marked as a duplicate of bug 1577277 ***


Note You need to log in before you can comment on or make changes to this bug.