Bug 1577480 - Null pointer exception while starting the volume from RHV Manager UI
Summary: Null pointer exception while starting the volume from RHV Manager UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhiv-1.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHHI-V 1.5
Assignee: Sahina Bose
QA Contact: Mugdha Soni
URL:
Whiteboard:
Depends On: 1577481
Blocks: 1520836
TreeView+ depends on / blocked
 
Reported: 2018-05-12 10:52 UTC by SATHEESARAN
Modified: 2018-11-08 05:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1577481 (view as bug list)
Environment:
Last Closed: 2018-11-08 05:39:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of the verification of the bug. (103.38 KB, image/png)
2018-06-20 07:27 UTC, Mugdha Soni
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3523 0 None None None 2018-11-08 05:39:53 UTC

Description SATHEESARAN 2018-05-12 10:52:30 UTC
Description of problem:
-----------------------
Create a replica 3 volume from RHV Manager UI and when starting the volume, observed error message in the UI, 'Failed to start the volume' though the volume actually started and its status become up in UI

When looking at the engine log, found a null pointer exception

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHV 4.2.3-6 and RHGS 3.3.1

How reproducible:
-----------------
Always

Steps to Reproduce:
--------------------
1. In a hyperconverged setup, create a new gluster volume from RHV Manager UI
2.  Start that volume from RHV Manager UI

Actual results:
---------------
null pointer exception in the engine.log

Expected results:
-----------------
starting the gluster volume from the RHV Manager UI should be successful

Additional info:

Comment 4 Mugdha Soni 2018-06-20 07:26:13 UTC
Tested with the following :-
(1) rhvh-4.2.4.2-0.20180613
(2) gdeploy-2.0.2-27.el7rhgs.noarch
(3) ansible-2.5.5-1.el7ae.noarch

The following are the steps performed for testing :
(1) Logged in to the RHV Manager UI and created a replica 3 volime from the UI.
(2) The volume was created successfully with no error message.
(3) There was no presence of null pointer in the engine log file.

Hence moving the bug to verified.

Comment 5 Mugdha Soni 2018-06-20 07:27:05 UTC
Created attachment 1453124 [details]
Screenshot of the verification of the bug.

Comment 7 errata-xmlrpc 2018-11-08 05:39:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3523


Note You need to log in before you can comment on or make changes to this bug.