Bug 1577481 - Null pointer exception while starting the volume from RHV Manager UI
Summary: Null pointer exception while starting the volume from RHV Manager UI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.3.5
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: ovirt-4.2.4
: ---
Assignee: Denis Chaplygin
QA Contact: Mugdha Soni
URL:
Whiteboard:
Depends On:
Blocks: 1577480
TreeView+ depends on / blocked
 
Reported: 2018-05-12 10:54 UTC by SATHEESARAN
Modified: 2018-06-26 08:38 UTC (History)
8 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of: 1577480
Environment:
Last Closed: 2018-06-26 08:38:26 UTC
oVirt Team: Gluster
sasundar: ovirt-4.2?
sasundar: planning_ack?
rule-engine: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)
engine.log (1.45 MB, application/x-gzip)
2018-05-12 11:03 UTC, SATHEESARAN
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 91131 None None None 2018-05-14 07:31:49 UTC
oVirt gerrit 91164 None None None 2018-05-14 07:31:26 UTC

Description SATHEESARAN 2018-05-12 10:54:20 UTC
Description of problem:
-----------------------
Create a replica 3 volume from RHV Manager UI and when starting the volume, observed error message in the UI, 'Failed to start the volume' though the volume actually started and its status become up in UI

When looking at the engine log, found a null pointer exception

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHV 4.2.3-6 and gluster-3.12

How reproducible:
-----------------
Always

Steps to Reproduce:
--------------------
1. In a hyperconverged setup, create a new gluster volume from RHV Manager UI
2.  Start that volume from RHV Manager UI

Actual results:
---------------
null pointer exception in the engine.log

Expected results:
-----------------
starting the gluster volume from the RHV Manager UI should be successful

Additional info:

Comment 1 SATHEESARAN 2018-05-12 11:03:45 UTC
Created attachment 1435369 [details]
engine.log

Comment 2 Doron Fediuck 2018-05-13 10:55:33 UTC
Although this should be fixed, I do think it's a corner case.
The main reason is that deployment is creating the replica 3 infrastructure using gdeploy, and the RHV UI flow is not used by default.
Can you confirm this?

Comment 3 Sahina Bose 2018-05-14 07:00:46 UTC
2018-05-12 15:50:00,776+05 ERROR [org.ovirt.engine.core.bll.gluster.RefreshGlusterVolumeDetailsCommand] (default task-36) [13c890f6] Exception: java.lang.NullPointerException
	at org.ovirt.engine.core.bll.gluster.GlusterSyncJob.refreshBrickDetails(GlusterSyncJob.java:1036) [bll.jar:]
	at org.ovirt.engine.core.bll.gluster.GlusterSyncJob.refreshVolumeDetails(GlusterSyncJob.java:1018) [bll.jar:]

Denis, I think you've already posted a patch to fix this?

Comment 4 Denis Chaplygin 2018-05-14 07:30:54 UTC
I think it is covered by https://gerrit.ovirt.org/91164/

Comment 5 Sandro Bonazzola 2018-05-25 08:00:43 UTC
referenced patches are included in ovirt-engine-4.2.4; moving to QE

Comment 6 Mugdha Soni 2018-06-20 07:30:13 UTC
Tested with the following :-
(1) rhvh-4.2.4.2-0.20180613
(2) gdeploy-2.0.2-27.el7rhgs.noarch
(3) ansible-2.5.5-1.el7ae.noarch

The following are the steps performed for testing :
(1) Logged in to the RHV Manager UI and created a replica 3 volime from the UI.
(2) The volume was created successfully with no error message.
(3) There was no presence of null pointer in the engine log file.

Hence moving the bug to verified.

Comment 7 Sandro Bonazzola 2018-06-26 08:38:26 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.