Bug 1577578 - heketi is not creating arbiter brick according to average file size.
Summary: heketi is not creating arbiter brick according to average file size.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: Michael Adam
QA Contact: Nitin Goyal
URL:
Whiteboard:
Depends On:
Blocks: 1568862
TreeView+ depends on / blocked
 
Reported: 2018-05-13 07:27 UTC by Nitin Goyal
Modified: 2018-05-14 14:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-14 14:14:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
These are output of running commands (4.59 KB, text/plain)
2018-05-13 07:34 UTC, Nitin Goyal
no flags Details
Heketi logs (18.22 MB, text/plain)
2018-05-13 07:49 UTC, Nitin Goyal
no flags Details

Description Nitin Goyal 2018-05-13 07:27:46 UTC
Description of problem: heketi is not creating arbiter brick according to average file size. I am creating a volume of 10 gb with avg file size 8kb, So it should 
not create arbiter brick of 154 mb(because it is default one).

Version-Release number of selected component (if applicable): 6.0.0.11

How reproducible:

Steps to Reproduce:
1. Create volume with avg size 8kb.
# heketi-cli volume create --size=4 --gluster-volume-options='user.heketi.arbiter true,user.heketi.heketi-average-file-size 8'

Actual results: It is creating arbiter brick of size 154 mb.

Expected results: It should create arbiter brick of size greater than 154 mb.

Comment 2 Nitin Goyal 2018-05-13 07:34:44 UTC
Created attachment 1435599 [details]
These are output of running commands

Comment 3 Nitin Goyal 2018-05-13 07:49:22 UTC
Created attachment 1435611 [details]
Heketi logs

Comment 4 Michael Adam 2018-05-14 11:03:53 UTC
Nitin, 

there is a typo in the readme, apparently:

the option is not called

user.heketi.heketi-average-file-size

but

user.heketi.average-file-size

Please try again using this.
I will file a PR to fix the readme.
But it should not impact functionality.

Cheers - Michael


Note You need to log in before you can comment on or make changes to this bug.