Bug 1577583 - unable to install qgis-grass on F28
Summary: unable to install qgis-grass on F28
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qgis
Version: 28
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Volker Fröhlich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-13 08:51 UTC by legocef
Modified: 2019-01-09 12:54 UTC (History)
10 users (show)

Fixed In Version: qgis-2.18.20-1.fc28 qgis-2.18.20-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-20 01:52:10 UTC
Type: Bug


Attachments (Terms of Use)

Description legocef 2018-05-13 08:51:43 UTC
Description of problem:

unable to install qgis-grass on F28

Version-Release number of selected component (if applicable):


How reproducible:

Try to install  :

dnf install qgis-grass


Actual results:

Error: 
 Problem: conflicting requests
  - nothing provides libgrass_datetime.7.2.2.so needed by qgis-grass-2.18.16-4.fc28.i686
  - nothing provides libgrass_datetime.7.2.2.so()(64bit) needed by qgis-grass-2.18.16-4.fc28.x86_64


Expected results:

package installed

Additional info:

Comment 1 Elia Devito 2018-05-23 17:18:56 UTC
confirm issue

Comment 2 Flo H. 2018-06-04 15:13:05 UTC
Same problem here

Comment 3 Flo H. 2018-06-04 15:34:00 UTC
Workaround: update gqis to version 3


I found this valuable compatibility matrix here: https://copr.fedorainfracloud.org/coprs/dani/qgis-testing/

Meaning, if you use QGIS 3.0.x from that COPR, you can install `grass` and `qgis-grass` from Fedora's repo.

Comment 4 Fedora Update System 2018-06-13 20:22:50 UTC
grass-7.4.1-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-e75f2b0b1a

Comment 5 Fedora Update System 2018-06-14 20:22:40 UTC
grass-7.4.1-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-e75f2b0b1a

Comment 6 Daniele Viganò 2018-06-17 09:46:36 UTC
Flo h.: you can also get QGIS 2, compiled against GRASS 7.4, here https://copr.fedorainfracloud.org/coprs/dani/qgis-ltr/

The problem is that 1) QGIS needs to be recompiled against any new version of GRASS 2) QGIS in min repos is too old (2.18.16 vs 2.18.20)

Actually both QGIS 2.18.20 and QGIS 3.0.3 supports GRASS 7.4, the problem is the QGIS available in official Fedora repos, not GRASS.

Comment 7 Daniele Viganò 2018-06-17 09:50:49 UTC
s/min repos/main repos/

Comment 8 Daniele Viganò 2018-06-17 10:13:34 UTC
This is anyway related to: https://bugzilla.redhat.com/show_bug.cgi?id=1585743

Comment 9 Fedora Update System 2018-06-18 07:08:33 UTC
qgis-2.18.20-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9ee3157c7d

Comment 10 Fedora Update System 2018-06-18 07:08:44 UTC
qgis-2.18.20-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5ea70554cb

Comment 11 Fedora Update System 2018-06-18 14:51:40 UTC
qgis-2.18.20-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9ee3157c7d

Comment 12 Fedora Update System 2018-06-18 17:08:23 UTC
qgis-2.18.20-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5ea70554cb

Comment 13 Fedora Update System 2018-06-20 01:52:10 UTC
qgis-2.18.20-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2018-06-28 13:33:31 UTC
qgis-2.18.20-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2018-06-30 09:59:46 UTC
grass-7.4.1-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-942d2b0be5

Comment 16 Fedora Update System 2018-07-01 05:06:50 UTC
grass-7.4.1-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-942d2b0be5

Comment 17 Fedora Update System 2018-07-11 20:17:44 UTC
grass-7.4.1-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.