Bug 1577871 - [geo-rep]: Geo-rep scheduler fails
Summary: [geo-rep]: Geo-rep scheduler fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 3.12
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On: 1575877 1576179 1611108
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-14 10:19 UTC by Kotresh HR
Modified: 2018-10-23 14:41 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.12.10
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1576179
Environment:
Last Closed: 2018-10-23 14:41:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2018-05-14 10:19:05 UTC
+++ This bug was initially created as a clone of Bug #1576179 +++

Description of problem:
=======================
A geo-rep session was started between a 6 node master and slave cluster.
While running the scheduler script, it failed with the following:


[    OK] Stopped Geo-replication
[    OK] Set Checkpoint
[    OK] Started Geo-replication and watching Status for Checkpoint completion
Traceback (most recent call last):
  File "/usr/share/glusterfs/scripts/schedule_georep.py", line 475, in <module>
    main(args)
  File "/usr/share/glusterfs/scripts/schedule_georep.py", line 394, in main
    slave_url)
  File "/usr/share/glusterfs/scripts/schedule_georep.py", line 342, in get_summary
    out.append([session_name, summary, faulty_rows, down_rows])
UnboundLocalError: local variable 'session_name' referenced before assignment


Version-Release number of selected component (if applicable):
============================================================
mainline

How reproducible:
================

1/1



Actual results:
===============
The geo-rep scheduler script fails

Expected results:
================
The scheduler should not fail

--- Additional comment from Worker Ant on 2018-05-09 01:17:24 EDT ---

REVIEW: https://review.gluster.org/19991 (geo-rep/scheduler: Fix crash) posted (#1) for review on master by Kotresh HR

--- Additional comment from Worker Ant on 2018-05-14 02:45:31 EDT ---

COMMIT: https://review.gluster.org/19991 committed in master by "Kotresh HR" <khiremat@redhat.com> with a commit message- geo-rep/scheduler: Fix crash

Fix crash where session_name is referenced
before assignment. Well, this is a corner
case where the geo-rep session exists and
the status output doesn't show any rows.
This might happen when glusterd is down
or when the system is in inconsistent state
w.r.t glusterd.

fixes: bz#1576179
Change-Id: Iec1557e01b35068041b4b3c1aacee2bfa0e05873
Signed-off-by: Kotresh HR <khiremat@redhat.com>

Comment 1 Kotresh HR 2018-05-14 10:23:04 UTC
https://review.gluster.org/20020

Comment 2 Worker Ant 2018-05-15 03:06:17 UTC
REVISION POSTED: https://review.gluster.org/20020 (geo-rep/scheduler: Fix crash) posted (#2) for review on release-3.12 by Kotresh HR

Comment 3 Worker Ant 2018-05-15 03:06:23 UTC
REVIEW: https://review.gluster.org/20020 (geo-rep/scheduler: Fix crash) posted (#2) for review on release-3.12 by Kotresh HR

Comment 4 Worker Ant 2018-06-11 10:19:17 UTC
COMMIT: https://review.gluster.org/20020 committed in release-3.12 by "jiffin tony Thottan" <jthottan@redhat.com> with a commit message- geo-rep/scheduler: Fix crash

Fix crash where session_name is referenced
before assignment. Well, this is a corner
case where the geo-rep session exists and
the status output doesn't show any rows.
This might happen when glusterd is down
or when the system is in inconsistent state
w.r.t glusterd.

Backport of:
> Patch: https://review.gluster.org/19991/
> Change-Id: Iec1557e01b35068041b4b3c1aacee2bfa0e05873
> Signed-off-by: Kotresh HR <khiremat@redhat.com>
(cherry picked from commit 829f32c61c364323bab494cf9dab880aad4be463)

fixes: bz#1577871
Change-Id: Iec1557e01b35068041b4b3c1aacee2bfa0e05873
Signed-off-by: Kotresh HR <khiremat@redhat.com>

Comment 5 Shyamsundar 2018-10-23 14:41:47 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.10, please open a new bug report.

glusterfs-3.12.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-May/000099.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.