Bug 1611108 - [geo-rep]: Geo-rep scheduler fails
Summary: [geo-rep]: Geo-rep scheduler fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On: 1575877 1576179
Blocks: 1577871
TreeView+ depends on / blocked
 
Reported: 2018-08-02 05:12 UTC by Kotresh HR
Modified: 2018-08-29 12:44 UTC (History)
8 users (show)

Fixed In Version: glusterfs-4.1.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1576179
Environment:
Last Closed: 2018-08-29 12:44:28 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2018-08-02 05:12:27 UTC
+++ This bug was initially created as a clone of Bug #1576179 +++

Description of problem:
=======================
A geo-rep session was started between a 6 node master and slave cluster.
While running the scheduler script, it failed with the following:


[    OK] Stopped Geo-replication
[    OK] Set Checkpoint
[    OK] Started Geo-replication and watching Status for Checkpoint completion
Traceback (most recent call last):
  File "/usr/share/glusterfs/scripts/schedule_georep.py", line 475, in <module>
    main(args)
  File "/usr/share/glusterfs/scripts/schedule_georep.py", line 394, in main
    slave_url)
  File "/usr/share/glusterfs/scripts/schedule_georep.py", line 342, in get_summary
    out.append([session_name, summary, faulty_rows, down_rows])
UnboundLocalError: local variable 'session_name' referenced before assignment


Version-Release number of selected component (if applicable):
============================================================
mainline

How reproducible:
================

1/1



Actual results:
===============
The geo-rep scheduler script fails

Expected results:
================
The scheduler should not fail

--- Additional comment from Worker Ant on 2018-05-09 01:17:24 EDT ---

REVIEW: https://review.gluster.org/19991 (geo-rep/scheduler: Fix crash) posted (#1) for review on master by Kotresh HR

--- Additional comment from Worker Ant on 2018-05-14 02:45:31 EDT ---

COMMIT: https://review.gluster.org/19991 committed in master by "Kotresh HR" <khiremat@redhat.com> with a commit message- geo-rep/scheduler: Fix crash

Fix crash where session_name is referenced
before assignment. Well, this is a corner
case where the geo-rep session exists and
the status output doesn't show any rows.
This might happen when glusterd is down
or when the system is in inconsistent state
w.r.t glusterd.

fixes: bz#1576179
Change-Id: Iec1557e01b35068041b4b3c1aacee2bfa0e05873
Signed-off-by: Kotresh HR <khiremat@redhat.com>

--- Additional comment from Worker Ant on 2018-05-14 23:06:17 EDT ---

REVISION POSTED: https://review.gluster.org/20020 (geo-rep/scheduler: Fix crash) posted (#2) for review on release-3.12 by Kotresh HR

Comment 1 Worker Ant 2018-08-02 05:55:59 UTC
REVIEW: https://review.gluster.org/20609 (geo-rep/scheduler: Fix crash) posted (#1) for review on release-4.1 by Kotresh HR

Comment 2 Worker Ant 2018-08-16 14:28:16 UTC
COMMIT: https://review.gluster.org/20609 committed in release-4.1 by "Kotresh HR" <khiremat@redhat.com> with a commit message- geo-rep/scheduler: Fix crash

Fix crash where session_name is referenced
before assignment. Well, this is a corner
case where the geo-rep session exists and
the status output doesn't show any rows.
This might happen when glusterd is down
or when the system is in inconsistent state
w.r.t glusterd.

Backpor of:
 > BUG: 1576179
 > Change-Id: Iec1557e01b35068041b4b3c1aacee2bfa0e05873
 > Signed-off-by: Kotresh HR <khiremat@redhat.com>

fixes: bz#1611108
Change-Id: Iec1557e01b35068041b4b3c1aacee2bfa0e05873
Signed-off-by: Kotresh HR <khiremat@redhat.com>

Comment 3 Shyamsundar 2018-08-29 12:44:28 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.1.3, please open a new bug report.

glusterfs-4.1.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-August/000111.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.