Bug 1578277 - Disable choose-local in groups virt for RHHI workloads
Summary: Disable choose-local in groups virt for RHHI workloads
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhi-1.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHHI-V 1.5
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1568297
Blocks: 1520836
TreeView+ depends on / blocked
 
Reported: 2018-05-15 07:40 UTC by SATHEESARAN
Modified: 2018-11-08 05:39 UTC (History)
11 users (show)

Fixed In Version: glusterfs-server-3.12.2-10
Doc Type: Bug Fix
Doc Text:
Previously, read requests were served from the local replica where possible because the cluster.choose-local option was enabled. This option has now been disabled, improving read performance by ensuring that read requests are distributed across all replicas.
Clone Of: 1568297
Environment:
Last Closed: 2018-11-08 05:39:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3523 None None None 2018-11-08 05:39:53 UTC

Description SATHEESARAN 2018-05-15 07:40:35 UTC
Description of problem:
------------------------

Sometime back when I was working on improving gluster performance for hyperconverged vm store workload, I'd seen ~6-8K iops improvement with random read fio test (run from 3 vms hosted on gluster volume).

Even Manoj (cc'd) reported better performance on gluster-block with choose-local disabled.

We're proposing to disable the option in groups virt and gluster-block in light of the above.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Krutika Dhananjay on 2018-04-12 04:28:28 EDT ---

Some data - http://post-office.corp.redhat.com/archives/rhgs-devel/2017-August/msg00065.html

--- Additional comment from Worker Ant on 2018-04-12 04:30:28 EDT ---

REVIEW: https://review.gluster.org/19855 (extras: Disable choose-local in groups virt and gluster-block) posted (#1) for review on master by Krutika Dhananjay

--- Additional comment from Worker Ant on 2018-04-13 06:23:30 EDT ---

COMMIT: https://review.gluster.org/19855 committed in master by "Pranith Kumar Karampuri" <pkarampu@redhat.com> with a commit message- extras: Disable choose-local in groups virt and gluster-block

Change-Id: Icba68406d86623195d59d6ee668e0850c037c63a
fixes: bz#1566386
Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>

--- Additional comment from Red Hat Bugzilla Rules Engine on 2018-04-17 03:51:42 EDT ---

This bug is automatically being proposed for the release of Red Hat Gluster Storage 3 under active development and open for bug fixes, by setting the release flag 'rhgs‑3.4.0' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

--- Additional comment from Krutika Dhananjay on 2018-04-17 13:12:31 EDT ---

Posted https://code.engineering.redhat.com/gerrit/#/c/135960/1 with a -1 until all acks are provided.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2018-05-15 02:43:48 EDT ---

This bug is automatically being provided 'pm_ack+' for the release flag 'rhgs‑3.4.0', having been appropriately marked for the release, and having been provided ACK from Development and QE

Comment 1 SATHEESARAN 2018-05-16 08:59:11 UTC
The glusterfs build carries the fix for this bug, and moving this bug ON_QA

Comment 5 SATHEESARAN 2018-05-16 10:24:51 UTC
Tested with glusterfs-3.12.2-10.el7rhgs, choose-local is turned 'off'

Comment 9 errata-xmlrpc 2018-11-08 05:39:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3523


Note You need to log in before you can comment on or make changes to this bug.