Bug 1578383 - Heketi is not creating volumes when we give very large average file size
Summary: Heketi is not creating volumes when we give very large average file size
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: CNS 3.10
Assignee: Michael Adam
QA Contact: Nitin Goyal
URL:
Whiteboard:
Depends On:
Blocks: 1568862
TreeView+ depends on / blocked
 
Reported: 2018-05-15 12:54 UTC by Nitin Goyal
Modified: 2018-09-12 09:23 UTC (History)
8 users (show)

Fixed In Version: heketi-6.0.0-13.el7rhgs
Doc Type: Bug Fix
Doc Text:
Heketi’s algorithm for creating a brick to be used by the arbiter feature creates the brick with a size smaller than the size of the data bricks, using an expected average file size factor that can be supplied by the user. Previously, supplying a large value for this file size factor created bricks too small to hold a file system. With this fix, Heketi sets a minimum brick size so that a valid file system can be created.
Clone Of:
Environment:
Last Closed: 2018-09-12 09:22:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2686 0 None None None 2018-09-12 09:23:23 UTC

Description Nitin Goyal 2018-05-15 12:54:51 UTC
Description of problem: Heketi is not creating a volumes when we are giving very large average file size when we are creating arbiter volume. It is because of the xfs minimum brick size condition is not met.

Version-Release number of selected component (if applicable): 6.0.0.12

How reproducible:

Steps to Reproduce:
1. heketi-cli volume create --size=10 --gluster-volume-options='user.heketi.arbiter true,user.heketi.average-file-size 1024'

Actual results: 
Error: Unable to execute command on glusterfs-storage-dz65l: agsize (3072 blocks) too small, need at least 4096 blocks
Usage: mkfs.xfs
/* blocksize */		[-b log=n|size=num]
/* metadata */		[-m crc=0|1,finobt=0|1,uuid=xxx]
/* data subvol */	[-d agcount=n,agsize=n,file,name=xxx,size=num,
			    (sunit=value,swidth=value|su=num,sw=num|noalign),
			    sectlog=n|sectsize=num
/* force overwrite */	[-f]
/* inode size */	[-i log=n|perblock=n|size=num,maxpct=n,attr=0|1|2,
			    projid32bit=0|1]
/* no discard */	[-K]
/* log subvol */	[-l agnum=n,internal,size=num,logdev=xxx,version=n
			    sunit=value|su=num,sectlog=n|sectsize=num,
			    lazy-count=0|1]
/* label */		[-L label (maximum 12 characters)]
/* naming */		[-n log=n|size=num,version=2|ci,ftype=0|1]
/* no-op info only */	[-N]
/* prototype file */	[-p fname]
/* quiet */		[-q]
/* realtime subvol */	[-r extsize=num,size=num,rtdev=xxx]
/* sectorsize */	[-s log=n|size=num]
/* version */		[-V]
			devicename


Expected results: It should create arbiter brick with minimum size.

Comment 6 Nitin Goyal 2018-06-11 13:08:43 UTC
Raghavendra Talur

It was fixed in heketi-6.0.0-13.el7rhgs
Can you put this ON QA

Comment 7 Anjana KD 2018-08-30 23:22:29 UTC
Updated doc text in the Doc Text field. Please review for technical accuracy.

Comment 9 Anjana KD 2018-09-05 09:38:08 UTC
updated the doc text based on feedback.

Comment 10 John Mulligan 2018-09-05 19:26:10 UTC
(In reply to Anjana from comment #9)
> updated the doc text based on feedback.

Looks OK to me.

Comment 12 errata-xmlrpc 2018-09-12 09:22:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2686


Note You need to log in before you can comment on or make changes to this bug.