Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1578418

Summary: Checks on bond mode are not effective
Product: [oVirt] ovirt-hosted-engine-setup Reporter: Simone Tiraboschi <stirabos>
Component: NetworkAssignee: Ido Rosenzwig <irosenzw>
Status: CLOSED CURRENTRELEASE QA Contact: Michael Burman <mburman>
Severity: high Docs Contact:
Priority: medium    
Version: 2.2.19CC: bugs, myakove, stirabos
Target Milestone: ovirt-4.2.4Flags: rule-engine: ovirt-4.2+
Target Release: 2.2.21   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ovirt-hosted-engine-setup-2.2.21 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-26 08:34:53 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Integration RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1581783    

Description Simone Tiraboschi 2018-05-15 14:29:50 UTC
Description of problem:
The user can try to deploy hosted-engine choosing a bond interface with invalid mode (0, 5, 6) and it will fail really late.

Version-Release number of selected component (if applicable):
2.2.20

How reproducible:
100%

Steps to Reproduce:
1. configure a bond in mode 0, 5 or 6
2. try to deploy hosted-engine choosing that bond
3. 

Actual results:
The bond will be accepted but the host will be set as non operational by the engine due to:
WARN  [org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand] (EE-ManagedThreadFactory-engine-Thread-1) [1408d11e] Validation of action 'HostSetupNetworks' failed for user admin@internal-authz. Reasons: VAR__ACTION__SETUP,VAR__TYPE__NETWORKS,INVALID_BOND_MODE_FOR_BOND_WITH_VM_NETWORK,$BondName bond0,$networkName ovirtmgmt

Expected results:
the user is not allowed to choose an invalid bond interface fro hosted-engine

Additional info:

Comment 1 Simone Tiraboschi 2018-05-15 14:31:29 UTC
(In reply to Simone Tiraboschi from comment #0)
> Additional info:

The code checks for 802.3adq instead of 802.3ad

Comment 2 Yaniv Kaul 2018-05-16 07:23:18 UTC
Severity...?

Comment 3 Yaniv Kaul 2018-05-24 10:11:59 UTC
(In reply to Yaniv Kaul from comment #2)
> Severity...?

Comment 4 Michael Burman 2018-06-01 10:28:48 UTC
Verified on - 
ovirt-hosted-engine-ha-2.2.13-1.el7ev.noarch
ovirt-hosted-engine-setup-2.2.22-1.el7ev.noarch

Cockpit - 
IF the host active connection is on top of a bond mode=0,5,6, the HE wizard won't be loaded and we failing with a very generic error:

'System data could not be retrieved!'

Can't start the HE deploy in such scenario, but we must to handle this generic error, will report a fresh bug to handle this. 

CLI-
If the host active connection is on top of a bond mode-0,5,6, the HE deploy is failed:
[ ERROR ] Failed to execute stage 'Environment customization': A Network interface is required
[ ERROR ] Hosted Engine deployment failed

Comment 5 Michael Burman 2018-06-03 09:11:22 UTC
Created new bug to handle the generic error on cockpit side - BZ 1585462

Comment 6 Sandro Bonazzola 2018-06-26 08:34:53 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.