Bug 1578823 - Remove EIO from the dht_inode_missing macro
Summary: Remove EIO from the dht_inode_missing macro
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
: 1505721 (view as bug list)
Depends On:
Blocks: 1277924 1579673 1579674 1580344
TreeView+ depends on / blocked
 
Reported: 2018-05-16 12:34 UTC by Nithya Balachandran
Modified: 2018-10-23 15:09 UTC (History)
2 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1579673 1580344 (view as bug list)
Environment:
Last Closed: 2018-10-23 15:09:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nithya Balachandran 2018-05-16 12:34:44 UTC
Description of problem:
commit a9ccd0c8ea6989c72 included EIO in the list of errnos that triggered a migration check task. This is therefore triggered in genuine cases of split brains as well.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-05-16 12:47:42 UTC
REVIEW: https://review.gluster.org/20028 (cluster/dht: Remove EIO from dht_inode_missing) posted (#1) for review on master by N Balachandran

Comment 2 Worker Ant 2018-05-17 06:49:36 UTC
COMMIT: https://review.gluster.org/20028 committed in master by "Raghavendra G" <rgowdapp@redhat.com> with a commit message- cluster/dht: Remove EIO from dht_inode_missing

Removed EIO from the list of errnos that triggered
a migrate check task.

Change-Id: I7f89c7a16056421588f1af2377cebe6affddcb47
fixes: bz#1578823
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 3 Nithya Balachandran 2018-10-08 04:53:04 UTC
*** Bug 1505721 has been marked as a duplicate of this bug. ***

Comment 4 Shyamsundar 2018-10-23 15:09:12 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.