Bug 1579673 - Remove EIO from the dht_inode_missing macro
Summary: Remove EIO from the dht_inode_missing macro
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.12
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On: 1578823 1580344
Blocks: 1277924 1579674
TreeView+ depends on / blocked
 
Reported: 2018-05-18 06:28 UTC by Nithya Balachandran
Modified: 2018-08-20 07:01 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.12.12
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1578823
: 1579674 (view as bug list)
Environment:
Last Closed: 2018-08-20 07:01:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nithya Balachandran 2018-05-18 06:28:32 UTC
+++ This bug was initially created as a clone of Bug #1578823 +++

Description of problem:
commit a9ccd0c8ea6989c72 included EIO in the list of errnos that triggered a migration check task. This is therefore triggered in genuine cases of split brains as well.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2018-05-16 08:47:42 EDT ---

REVIEW: https://review.gluster.org/20028 (cluster/dht: Remove EIO from dht_inode_missing) posted (#1) for review on master by N Balachandran

--- Additional comment from Worker Ant on 2018-05-17 02:49:36 EDT ---

COMMIT: https://review.gluster.org/20028 committed in master by "Raghavendra G" <rgowdapp@redhat.com> with a commit message- cluster/dht: Remove EIO from dht_inode_missing

Removed EIO from the list of errnos that triggered
a migrate check task.

Change-Id: I7f89c7a16056421588f1af2377cebe6affddcb47
fixes: bz#1578823
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 1 Worker Ant 2018-05-18 07:02:04 UTC
REVIEW: https://review.gluster.org/20033 (cluster/dht: Remove EIO from dht_inode_missing) posted (#1) for review on release-3.12 by N Balachandran

Comment 2 Worker Ant 2018-06-12 08:47:44 UTC
REVIEW: https://review.gluster.org/20033 (cluster/dht: Remove EIO from dht_inode_missing) posted (#2) for review on release-3.12 by N Balachandran

Comment 3 Worker Ant 2018-06-22 09:20:37 UTC
REVIEW: https://review.gluster.org/20033 (cluster/dht: Remove EIO from dht_inode_missing) posted (#3) for review on release-3.12 by N Balachandran

Comment 4 Worker Ant 2018-07-04 04:03:12 UTC
COMMIT: https://review.gluster.org/20033 committed in release-3.12 by "jiffin tony Thottan" <jthottan@redhat.com> with a commit message- cluster/dht: Remove EIO from dht_inode_missing

Removed EIO from the list of errnos that triggered
a migrate check task.

(cherry picked from commit c925962b91c67c8cd2391df7dd0251e0cbf66648)

Change-Id: I7f89c7a16056421588f1af2377cebe6affddcb47
BUG: 1579673
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 5 Jiffin 2018-08-20 07:01:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.12, please open a new bug report.

glusterfs-3.12.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-July/000105.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.