Bug 157913 - [PATCH] unable a delete a composed indic character in a single keypress
[PATCH] unable a delete a composed indic character in a single keypress
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
FF3RawhideClose
: i18n
: 204932 (view as bug list)
Depends On: 142699
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-16 21:32 EDT by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:47:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
proposed patch (1.57 KB, patch)
2006-08-17 05:06 EDT, Akira TAGOH
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 348838 None None None Never

  None (edit)
Description Lawrence Lim 2005-05-16 21:32:59 EDT
+++ This bug was initially created as a clone of Bug #142699 +++

Description of problem:
Further to bug 138661, during editing the delete key does not delete the whole
composed character (unlike gtk+ applications like gedit).

How reproducible:
ALways

Steps to Reproduce:
1. load
http://bob.brisbane.redhat.com/eng/indic/hindi/BrowserTest_Hindi.html
2. go to text box area
3. try to delete an indic character by using BackSpace
  
Actual results:
Unable to delete the whole char with a single BackSpace

Expected results:
Able to delete the whole char using a single BackSpace

Additional info:
Comment 1 Lawrence Lim 2005-05-16 21:34:47 EDT
Updating the description to reflect the current behaviour of gtk+.

Description of problem:
Further to bug 138661, during editing, the 'Delete' key does not delete the whole
composed character (unlike gtk+ applications like gedit).

How reproducible:
ALways

Steps to Reproduce:
1. load
http://bob.brisbane.redhat.com/eng/indic/hindi/BrowserTest_Hindi.html
2. go to text box area
3. try to delete an indic character by using  the 'Delete' key
 
Actual results:
Unable to delete the whole char with a single 'Delete' keypress

Expected results:
Able to delete the whole char using a single 'Delete' keypress

Additional info:
In gtk apps, Delete removes the whole composed character in one keypress while
Backspace remove the charcters which made up of the composed character one at a
time.
Comment 2 Akira TAGOH 2006-08-17 05:06:37 EDT
Created attachment 134372 [details]
proposed patch

attached a patch to fix this issue. I've tested the above URL on firefix with
this patch. and the deletion works fine.
Comment 3 Christopher Blizzard 2006-08-17 08:55:59 EDT
I'm not positive but you should also make sure that there's not an html editor
equivelent problem.  That's used for midas (the HTML rich editor component) and
the HTML editor used in thunderbird.  Once again, not sure if they are different
components entirely or if they work today, but it's worth looking into.
Comment 4 Akira TAGOH 2006-08-17 09:14:07 EDT
Sure. you're right. I think there are a class for HTML editor. I'll look into
this too. thanks for letting me know.
Comment 5 Akira TAGOH 2006-08-17 09:49:50 EDT
just for updates, it also works on midas demo page at least
(http://www.mozilla.org/editor/midasdemo/). is this what you told, right?

BTW this problem still appears on thunderbird as expected unfortunately. but it
should be filed separately IMHO.
Comment 6 Akira TAGOH 2006-08-18 01:32:06 EDT
filed a bug for thunderbird as Bug#203060.
Comment 7 Akira TAGOH 2006-08-18 04:49:55 EDT
ah, ok. thunderbird just needs the same patch to fix the same problem. no need
to apply any patches futhermore.
Comment 8 Akira TAGOH 2006-09-03 23:26:06 EDT
*** Bug 204932 has been marked as a duplicate of this bug. ***
Comment 9 Christopher Aillon 2006-09-14 22:48:31 EDT
Upstream seems to imply the patch needs work, see
http://bugzilla.mozilla.org/show_bug.cgi?id=348838

Need patches to be generally accepted upstream before we can add them to our RPMs.
Comment 10 Matthias Clasen 2006-09-15 15:13:06 EDT
Given the "must be upstream first" policy for mozilla patches, these bugs can't
block FC6
Comment 11 Satyabrata Maitra 2007-12-11 07:20:30 EST
The same bug found in FC8 released version as well.

version  of the component tested :-
firefox-2.0.0.8-2.fc8

Delete key is not deleting the whole composed char in a single key press.
(When use delete key, the cursor should be placed on the left hand side of the
composed char, and tested in this way infact)
Comment 12 Matěj Cepl 2007-12-20 11:47:13 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays
Comment 13 Parag Nemade 2008-04-10 02:15:55 EDT
Tested this with firefox-3.0-0.53.beta5.fc9.i386 rawhide rpm today. Found this
is resolved.
Current behaviour in Firefox is like this
composed character can be deleted in single "delete" keypress
composed character can be modified in multiple "backspace" keypress or deleted
in multiple "delete" keypress.

This is exactly same behaviour as tested using gedit(gtk application)

Note You need to log in before you can comment on or make changes to this bug.