Bug 204932 - [Indic] DELETE key not deleting char in a single keystroke.
[Indic] DELETE key not deleting char in a single keystroke.
Status: CLOSED DUPLICATE of bug 157913
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-01 09:58 EDT by Satyabrata Maitra
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-03 23:25:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satyabrata Maitra 2006-09-01 09:58:12 EDT
Description of problem:
Open the URL :
http://batman.brisbane.redhat.com/~indic/IndicTC/lang/si_LK/font/IndicFontTestCaseGSUB-Sinhala.html

The Delete key should delete the entire composed char withe a single keystroke.

Version-Release number of selected component (if applicable):
firefox-1.5.0.6-8

How reproducible:
Possibly be always

Steps to Reproduce:
1. Open the above mentioned URL.
2. Place the cursor at the right-hand side of the char (left hand side of your 
   own) in the text box given.
3. Press DELETE key.
4. Observe the result
  
Actual results:
Delete key is deleting the single composed char one by one. (can see it)

Expected results:
The DELETE key should delete the entire char with a single keystroke.


Additional info:
can try to other langs also. URLs are :
http://batman.brisbane.redhat.com/~indic/IndicTC/lang/ml_IN/font/IndicFontTestCaseGSUB-Malayalam.html
http://batman.brisbane.redhat.com/~indic/IndicTC/lang/kn_IN/font/IndicFontTestCaseGSUB-Kannada.html
etc.

OR can open anything in firefox where there are text boxes to enter texts and
observe the cursor movements.
Comment 1 Akira TAGOH 2006-09-03 23:25:44 EDT

*** This bug has been marked as a duplicate of 157913 ***

Note You need to log in before you can comment on or make changes to this bug.