Bug 1580238 - Fix incorrect rebalance log message
Summary: Fix incorrect rebalance log message
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1583769
TreeView+ depends on / blocked
 
Reported: 2018-05-21 05:05 UTC by Nithya Balachandran
Modified: 2018-10-23 15:09 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1583769 (view as bug list)
Environment:
Last Closed: 2018-10-23 15:09:43 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nithya Balachandran 2018-05-21 05:05:08 UTC
Description of problem:

The following message is logged in the rebalance logs:
[2018-05-18 14:02:09.725546] W [MSGID: 0] [dht-rebalance.c:2379:dht_migrate_file] 0-gd2vol-distribute: /dir/xfile-24: removexattr failed key glusterfs.clean.writexattr [No data available]


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-05-21 05:38:10 UTC
REVIEW: https://review.gluster.org/20043 (cluster/dht: Fix rebalance log msg) posted (#1) for review on master by N Balachandran

Comment 2 Worker Ant 2018-05-24 05:54:35 UTC
COMMIT: https://review.gluster.org/20043 committed in master by "Raghavendra G" <rgowdapp@redhat.com> with a commit message- cluster/dht: Fix rebalance log msg

Corrected the name of the xattr and fixed
the code to log an error only if op_errno
is not ENODATA or ENOATTR.

Change-Id: I42c5b1d838eec586ac7bed2471eb1d27ff09a9ea
fixes: bz#1580238
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 3 Worker Ant 2018-05-30 04:08:56 UTC
REVIEW: https://review.gluster.org/20100 (cluster:dht: Corrected ret code check) posted (#1) for review on master by N Balachandran

Comment 4 Worker Ant 2018-05-31 01:47:30 UTC
COMMIT: https://review.gluster.org/20100 committed in master by "N Balachandran" <nbalacha@redhat.com> with a commit message- cluster:dht: Corrected ret code check

syncop functions return -op_errno.

Change-Id: Ifdb1bd1d1d11972b4306a2336e6737d6236a2fb1
fixes: bz#1580238
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 5 Shyamsundar 2018-10-23 15:09:43 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.