Bug 1583769 - Fix incorrect rebalance log message
Summary: Fix incorrect rebalance log message
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On: 1580238
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-29 15:56 UTC by Nithya Balachandran
Modified: 2018-06-20 18:07 UTC (History)
1 user (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1580238
Environment:
Last Closed: 2018-06-20 18:07:27 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nithya Balachandran 2018-05-29 15:56:11 UTC
+++ This bug was initially created as a clone of Bug #1580238 +++

Description of problem:

The following message is logged in the rebalance logs:
[2018-05-18 14:02:09.725546] W [MSGID: 0] [dht-rebalance.c:2379:dht_migrate_file] 0-gd2vol-distribute: /dir/xfile-24: removexattr failed key glusterfs.clean.writexattr [No data available]


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2018-05-21 01:38:10 EDT ---

REVIEW: https://review.gluster.org/20043 (cluster/dht: Fix rebalance log msg) posted (#1) for review on master by N Balachandran

--- Additional comment from Worker Ant on 2018-05-24 01:54:35 EDT ---

COMMIT: https://review.gluster.org/20043 committed in master by "Raghavendra G" <rgowdapp@redhat.com> with a commit message- cluster/dht: Fix rebalance log msg

Corrected the name of the xattr and fixed
the code to log an error only if op_errno
is not ENODATA or ENOATTR.

Change-Id: I42c5b1d838eec586ac7bed2471eb1d27ff09a9ea
fixes: bz#1580238
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 1 Worker Ant 2018-05-29 16:05:38 UTC
REVIEW: https://review.gluster.org/20099 (cluster/dht: Fix rebalance log msg) posted (#1) for review on release-4.1 by N Balachandran

Comment 2 Worker Ant 2018-05-31 13:14:05 UTC
COMMIT: https://review.gluster.org/20099 committed in release-4.1 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- cluster/dht: Fix rebalance log msg

Corrected the name of the xattr and fixed
the code to log an error only if op_errno
is not ENODATA or ENOATTR.

Change-Id: I42c5b1d838eec586ac7bed2471eb1d27ff09a9ea
fixes: bz#1583769
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 3 Shyamsundar 2018-06-20 18:07:27 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.