Bug 1582106 - 12->13 upgrade fails in the converge part for monolithic with mds deployment
Summary: 12->13 upgrade fails in the converge part for monolithic with mds deployment
Keywords:
Status: CLOSED DUPLICATE of bug 1588619
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: ---
Assignee: Giulio Fidente
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-24 08:53 UTC by Gal Amado
Modified: 2018-06-08 13:08 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-08 13:08:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gal Amado 2018-05-24 08:53:18 UTC
Description of problem:
The upgrade process of monolithic deployment with nds fails in the converge phase 

How reproducible:


Steps to Reproduce:
1.
During the upgrade prosess, trying to run from the undercloud:
 
openstack overcloud upgrade converge \
--templates \
-e /usr/share/openstack-tripleo-heat-templates/environments/lifecycle/upgrade-converge.yaml \
-e /home/stack/virt/internal.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /home/stack/virt/network/network-environment.yaml \
-e /home/stack/virt/hostnames.yml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ceph-ansible/ceph-ansible.yaml \
-e /home/stack/virt/debug.yaml \
-e /home/stack/virt/nodes_data.yaml \
--environment-file /usr/share/openstack-tripleo-heat-templates/environments/cinder-backup.yaml \
--environment-file /usr/share/openstack-tripleo-heat-templates/environments/ceph-ansible/ceph-mds.yaml \
--environment-file /usr/share/openstack-tripleo-heat-templates/environments/manila-cephfsnative-config.yaml \
-e /home/stack/virt/docker-images.yaml \
-r /usr/share/openstack-tripleo-heat-templates/roles_data.yaml

Actual results:
"Error: Evaluation Error: Error while evaluating a Function Call, Could not find data item manila::backend::cephfsnative::title in any Hiera data file and no default supplied at /etc/
puppet/modules/tripleo/manifests/profile/base/manila/share.pp:99:38 on node controller-1.localdomain",

Comment 7 Yogev Rabl 2018-06-08 13:08:50 UTC

*** This bug has been marked as a duplicate of bug 1588619 ***


Note You need to log in before you can comment on or make changes to this bug.