Bug 1588619 - Typo in Manila Share Template Causes Upgrades to Fail
Summary: Typo in Manila Share Template Causes Upgrades to Fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 13.0 (Queens)
Assignee: Dustin Schoenbrun
QA Contact: Vince Green
URL:
Whiteboard:
: 1582106 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-07 16:03 UTC by Dustin Schoenbrun
Modified: 2018-06-27 13:58 UTC (History)
13 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-32.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:57:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
Lines showing failure in upgrade output. (1.22 KB, text/plain)
2018-06-07 16:03 UTC, Dustin Schoenbrun
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 573373 None None None 2018-06-07 19:22:23 UTC
OpenStack gerrit 573877 None None None 2018-06-10 12:42:56 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:58:15 UTC

Description Dustin Schoenbrun 2018-06-07 16:03:41 UTC
Created attachment 1448780 [details]
Lines showing failure in upgrade output.

Description of problem:
When performing an upgrade from OSP-12 to OSP-13 with Manila, the upgrade steps will fail due to a typo in the manila-share.yaml file in the pacemaker configuration. This will cause any environment with Manila to fail during an upgrade.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-8.0.2-29.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Configure an OSP-12 installation with one undercloud, three controllers, and two compute nodes and ensure that Manila is configured and deployed on the controller nodes.
2. Attempt to upgrade the OSP-12 installation to OSP-13.
3. Observe that the upgrade procedure fails due to  u'fatal: [192.168.24.6]: FAILED! => {"msg": "\'manila_share_containers_to_destroy\' is undefined"}',


Actual results:
The upgrade procedure fails with the error given above. 

Expected results:
The upgrade procedure shall succeed.

Comment 6 Yogev Rabl 2018-06-08 13:08:50 UTC
*** Bug 1582106 has been marked as a duplicate of this bug. ***

Comment 15 Yogev Rabl 2018-06-11 14:53:12 UTC
Verified

Comment 16 Vince Green 2018-06-11 15:03:35 UTC
Dustin did a typo-workaround test to verify with tempest afterwards and Yogev did an upgrade on the puddle last week, just for documentation on the bug.

Comment 19 errata-xmlrpc 2018-06-27 13:57:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.