Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1582857

Summary: Unable to delete servicebinding
Product: OpenShift Container Platform Reporter: hgomes
Component: Service CatalogAssignee: Jeff Peeler <jpeeler>
Status: CLOSED DUPLICATE QA Contact: Jian Zhang <jiazha>
Severity: high Docs Contact:
Priority: unspecified    
Version: 3.9.0CC: aos-bugs, chezhang, hgomes, jaboyd, jiazha, jmatthew, jpeeler, tsanders, zhsun, zitang
Target Milestone: ---   
Target Release: 3.9.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-18 15:49:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description hgomes 2018-05-27 14:23:42 UTC
Description of problem:

The deletion of the secret of the servicebinding was performed, but deleting the resource did not work as expected

When trying to delete the lines from the resource it fails with message:

     finalizers:
     - kubernetes-incubator/service-catalog
One of the examples provided,

# oc edit servicebindings postgresql-persistent-xxxxxx
error: servicebindings "postgresql-persistent-xxxxxx" is invalid
error: servicebindings "postgresql-persistent-xxxxxx" is invalid
A copy of your changes has been stored to "/tmp/oc-edit-b9bzr.yaml"
error: Edit cancelled, no valid changes were saved.

The error when editing:

# servicebindings "postgresql-persistent-xxxxx" was not valid:
# * status.unbindStatus: Unsupported value: "": supported values: "Succeeded", "Failed", "NotRequired", "Required"

Looks that we might be hitting some sort of bug for this.

Comment 2 John Matthews 2018-05-29 17:48:06 UTC
I think this issue relates to Service Catalog, changing the component.

Comment 4 Jeff Peeler 2018-05-29 19:57:07 UTC
This is the same as https://bugzilla.redhat.com/show_bug.cgi?id=1566328, but collecting information about how the binding got into this state would be appreciated.

Comment 9 Jeff Peeler 2018-06-18 15:49:09 UTC
Fix has been committed on duplicate bug: https://bugzilla.redhat.com/show_bug.cgi?id=1586135#c1

*** This bug has been marked as a duplicate of bug 1586135 ***