Bug 1586135 - Upgrade from 3.7 to 3.9 fail at the Task [Upgrade all storage] for servicebinding (fix for 3.9.z)
Summary: Upgrade from 3.7 to 3.9 fail at the Task [Upgrade all storage] for servicebin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.9.z
Assignee: Jeff Peeler
QA Contact: Jian Zhang
URL:
Whiteboard:
: 1582857 (view as bug list)
Depends On: 1566328
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-05 14:58 UTC by Paul Morie
Modified: 2018-07-18 09:19 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This ensures spec validations don't include status, such that storage migrations during upgrade properly succeed.
Clone Of: 1566328
Environment:
Last Closed: 2018-07-18 09:18:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2213 None None None 2018-07-18 09:19:28 UTC

Comment 1 Jeff Peeler 2018-06-08 14:20:06 UTC
Unmerged PR: https://github.com/openshift/origin/pull/19919 (currently blocked by a CI issue)

Comment 2 Jeff Peeler 2018-06-18 15:49:09 UTC
*** Bug 1582857 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2018-07-18 09:18:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2213


Note You need to log in before you can comment on or make changes to this bug.