Bug 1583082 - SELinux is preventing /usr/bin/pkla-check-authorization from map access on the file /usr/bin/pkla-check-authorization
Summary: SELinux is preventing /usr/bin/pkla-check-authorization from map access on th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
: 1574389 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-28 08:11 UTC by Lukas Slebodnik
Modified: 2018-10-30 10:04 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-203.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:04:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:04:48 UTC

Description Lukas Slebodnik 2018-05-28 08:11:48 UTC
SELinux is preventing /usr/bin/pkla-check-authorization from map access on the file /usr/bin/pkla-check-authorization.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that pkla-check-authorization should be allowed map access on the pkla-check-authorization file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'pkla-check-auth' --raw | audit2allow -M my-pklacheckauth
# semodule -i my-pklacheckauth.pp


Additional Information:
Source Context                system_u:system_r:policykit_t:s0
Target Context                system_u:object_r:policykit_auth_exec_t:s0
Target Objects                /usr/bin/pkla-check-authorization [ file ]
Source                        pkla-check-auth
Source Path                   /usr/bin/pkla-check-authorization
Port                          <Unknown>
Host                          bkr-hv01-guest24.example.com
Source RPM Packages           polkit-pkla-compat-0.1-4.el7.x86_64
Target RPM Packages           polkit-pkla-compat-0.1-4.el7.x86_64
Policy RPM                    selinux-policy-3.13.1-197.el7.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Platform                      Linux bkr-hv01-guest24.example.com
                              3.10.0-893.el7.x86_64 #1 SMP Thu May 24 21:37:14
                              UTC 2018 x86_64 x86_64
Alert Count                   1
First Seen                    2018-05-26 09:14:55 EDT
Last Seen                     2018-05-26 09:14:55 EDT
Local ID                      14749943-b4f1-4345-9bbd-f6ec464670f2

Raw Audit Messages
type=AVC msg=audit(1527340495.671:120): avc:  denied  { map } for  pid=15650 comm="pkla-check-auth" path="/usr/bin/pkla-check-authorization" dev="dm-0" ino=116366 scontext=system_u:system_r:policykit_t:s0 tcontext=system_u:object_r:policykit_auth_exec_t:s0 tclass=file permissive=1


type=SYSCALL msg=audit(1527340495.671:120): arch=x86_64 syscall=execve success=yes exit=0 a0=557b159d5290 a1=557b15998dd0 a2=7ffe6eca7a70 a3=7ffe6eca6360 items=0 ppid=638 pid=15650 auid=4294967295 uid=999 gid=998 euid=999 suid=999 fsuid=999 egid=998 sgid=998 fsgid=998 tty=(none) ses=4294967295 comm=pkla-check-auth exe=/usr/bin/pkla-check-authorization subj=system_u:system_r:policykit_auth_t:s0 key=(null)

Hash: pkla-check-auth,policykit_t,policykit_auth_exec_t,file,map

Comment 2 Lukas Vrabec 2018-06-03 16:05:02 UTC
*** Bug 1574389 has been marked as a duplicate of this bug. ***

Comment 3 Milos Malik 2018-06-07 21:09:10 UTC
----
type=PROCTITLE msg=audit(06/07/2018 17:05:17.385:337) : proctitle=(null) 
type=PATH msg=audit(06/07/2018 17:05:17.385:337) : item=1 name=/lib64/ld-linux-x86-64.so.2 inode=418713 dev=fd:00 mode=file,755 ouid=root ogid=root rdev=00:00 obj=system_u:object_r:ld_so_t:s0 objtype=NORMAL cap_fp=none cap_fi=none cap_fe=0 cap_fver=0 
type=PATH msg=audit(06/07/2018 17:05:17.385:337) : item=0 name=/usr/bin/pkla-check-authorization inode=12909515 dev=fd:00 mode=file,755 ouid=root ogid=root rdev=00:00 obj=system_u:object_r:policykit_auth_exec_t:s0 objtype=NORMAL cap_fp=none cap_fi=none cap_fe=0 cap_fver=0 
type=CWD msg=audit(06/07/2018 17:05:17.385:337) :  cwd=/ 
type=SYSCALL msg=audit(06/07/2018 17:05:17.385:337) : arch=x86_64 syscall=execve success=no exit=EACCES(Permission denied) a0=0x55ee9f7266d0 a1=0x55ee9f7268c0 a2=0x7ffe0e1972e0 a3=0x7ffe0e195ae0 items=2 ppid=671 pid=11562 auid=unset uid=polkitd gid=polkitd euid=polkitd suid=polkitd fsuid=polkitd egid=polkitd sgid=polkitd fsgid=polkitd tty=(none) ses=unset comm=pkla-check-auth exe=/usr/bin/pkla-check-authorization subj=system_u:system_r:policykit_t:s0 key=(null) 
type=AVC msg=audit(06/07/2018 17:05:17.385:337) : avc:  denied  { map } for  pid=11562 comm=pkla-check-auth path=/usr/bin/pkla-check-authorization dev="dm-0" ino=12909515 scontext=system_u:system_r:policykit_t:s0 tcontext=system_u:object_r:policykit_auth_exec_t:s0 tclass=file permissive=0 
----

Comment 7 errata-xmlrpc 2018-10-30 10:04:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.