Bug 1583242 - Hammer doesn't support Quota option for RHEV
Summary: Hammer doesn't support Quota option for RHEV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources - RHEV
Version: 6.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: 6.6.0
Assignee: orabin
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On: 1501927
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-28 14:24 UTC by Lukáš Hellebrandt
Modified: 2019-11-18 18:32 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-22 19:51:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 23976 'Normal' 'Closed' 'Hammer doesn''t support Quota option for RHEV' 2019-11-18 18:28:16 UTC
Red Hat Bugzilla 1583243 'unspecified' 'CLOSED' 'RHEV without Quota ID specified -> Traceback + Alert' 2019-11-18 18:28:16 UTC

Internal Links: 1583243

Description Lukáš Hellebrandt 2018-05-28 14:24:11 UTC
Description of problem:
'hammer compute-resource create' command doesn't support specifying Quota ID as WebUI does.

Version-Release number of selected component (if applicable):
Tested with Sat6.4, Hammer 0.13.0

How reproducible:
Deterministic

Steps to Reproduce:
hammer compute-resource create --help | grep -i quota

Actual results:
No --quota or similar parameter

Expected results:
Quota should be specifiable

Comment 2 orabin 2018-06-18 11:54:45 UTC
Created redmine issue http://projects.theforeman.org/issues/23976 from this bug

Comment 3 pm-sat@redhat.com 2018-06-18 12:20:18 UTC
Upstream bug assigned to orabin@redhat.com

Comment 4 pm-sat@redhat.com 2018-06-18 12:20:22 UTC
Upstream bug assigned to orabin@redhat.com

Comment 5 pm-sat@redhat.com 2018-06-19 16:24:35 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/23976 has been resolved.

Comment 6 Lukáš Hellebrandt 2018-07-16 09:58:25 UTC
FailedQA with Sat 6.4 snap 12.

The Quota isn't set by either 'hammer create' or 'hammer update'. The field is left empty. This might be caused by bug 1583243 still not being fixed. Anyway, the result is that the Quota can't be set by Hammer in the current snap -> failed.

Comment 7 Lukáš Hellebrandt 2018-07-16 10:00:50 UTC
^ I mean bug 1501927

Comment 8 orabin 2018-08-09 09:39:28 UTC
When: https://bugzilla.redhat.com/show_bug.cgi?id=1501927 is merged I suggest to move this to ON_QA again.

Comment 10 orabin 2019-03-12 09:27:12 UTC
Moving to on_qa because the bug it depends on is also on_qa.
Please note - ovirt-quota expects an id and not a name.
There is an RFE to change that but this is currently the expected behavior.

Comment 11 Lukáš Hellebrandt 2019-05-29 12:57:13 UTC
Verified with Sat 6.6 snap 4.

It is possible to set Quota for a new CR, it is possible to update Quota in an existing CR. It is possible not to set any Quota (so default Quota is used).

To get Quota ID, I ran ovirt-shell in the RHEV server's command line and inside, I ran "list quotas --parent-datacenter-name <datacenter-name>".

Comment 13 Bryan Kearney 2019-10-22 19:51:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:3172


Note You need to log in before you can comment on or make changes to this bug.