Bug 1583333 - THT should default to setting ceph pool application type when using luminous
Summary: THT should default to setting ceph pool application type when using luminous
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z2
: 13.0 (Queens)
Assignee: John Fulton
QA Contact: Yogev Rabl
URL:
Whiteboard:
: 1598046 1626647 (view as bug list)
Depends On: 1562220
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-28 18:54 UTC by John Fulton
Modified: 2019-03-28 14:05 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.4-3.el7ost
Doc Type: Bug Fix
Doc Text:
Cause: Not all Ceph pools had an application type set. Consequence: Ceph would emit a HEALTH_WARN message because not every pools created during the deployment had an application type set. Fix: Apply an appliation type to every pool created during the deployment. Result: Ceph status does not warn about any pool missing an application type.
Clone Of:
Environment:
Last Closed: 2018-08-29 16:36:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1772743 None None None 2018-05-28 18:54:11 UTC
OpenStack gerrit 570043 None master: MERGED tripleo-heat-templates: Set default application for Ceph Luminous openstack_pools (I3966a8a1b170202e020684a36ecece785992... 2018-07-19 01:54:12 UTC
OpenStack gerrit 571196 None stable/queens: MERGED tripleo-heat-templates: Set default application for Ceph Luminous openstack_pools (I3966a8a1b170202e020684a36ecece785992... 2018-07-19 01:54:07 UTC
Red Hat Product Errata RHBA-2018:2574 None None None 2018-08-29 16:37:34 UTC

Description John Fulton 2018-05-28 18:54:12 UTC
Luminous can assign application types to pools [1] and ceph-ansible supports this [2] provided you pass it a list of maps like the following:

openstack_pools:
- {name: images, pg_num: 32, rule_name: '', application: 'rbd'}
- {name: metrics, pg_num: 32, rule_name: '', application: 'openstack_gnocchi'}
- {name: backups, pg_num: 32, rule_name: '', application: 'rbd'}
- {name: vms, pg_num: 32, rule_name: '', application: 'rbd'}
- {name: volumes, pg_num: 32, rule_name: '', application: 'rbd'}

TripleO supports passing a structure like the above by allowing the user to directly override the openstack_pools value as above. However starting with Queens, which supports Luminous, it should default to passing something like the above. This includes passing application type "rbd" by default for OpenStack pools with the exception of the metrics pool, which should be of application type "openstack_gnocchi".

[1] http://docs.ceph.com/docs/luminous/rados/operations/pools/#associate-pool-to-application
[2] https://github.com/ceph/ceph-ansible/blob/master/roles/ceph-mon/tasks/openstack_config.yml#L35

Comment 3 John Fulton 2018-05-30 12:50:56 UTC
Master change has merged but I need this backported to queens before I can mark post.

 https://review.openstack.org/#/c/571196/

Comment 5 John Fulton 2018-07-18 22:08:21 UTC
*** Bug 1598046 has been marked as a duplicate of this bug. ***

Comment 16 John Fulton 2018-08-13 16:27:07 UTC
How to reproduce:

Deploy the overcloud and SSH into one of the monitors and run `ceph osd dump | grep pool`. The bug is fixed if you see an application tag listed for each pool. 

In the example below, you see that each pool has "rbd" after "application" with the exception of metrics which has the application tag "openstack_gnocchi".

# ceph osd dump | grep pool
pool 1 'images' replicated size 3 min_size 2 crush_rule 0 object_hash rjenkins pg_num 2048 pgp_num 2048 last_change 1120 lfor 0/1118 flags hashpspool stripe_width 0 application rbd
pool 2 'metrics' replicated size 3 min_size 2 crush_rule 0 object_hash rjenkins pg_num 1024 pgp_num 1024 last_change 148 flags hashpspool stripe_width 0 application openstack_gnocchi
pool 3 'backups' replicated size 3 min_size 2 crush_rule 0 object_hash rjenkins pg_num 1024 pgp_num 1024 last_change 131 flags hashpspool stripe_width 0
pool 4 'vms' replicated size 3 min_size 2 crush_rule 0 object_hash rjenkins pg_num 4096 pgp_num 4096 last_change 1129 lfor 0/1127 flags hashpspool stripe_width 0 application rbd
pool 5 'volumes' replicated size 3 min_size 2 crush_rule 0 object_hash rjenkins pg_num 61741 pgp_num 61741 last_change 1175 lfor 0/1173 flags hashpspool stripe_width 0 application rbd
(overcloud) 
root@overcloud-controller-0:~
#

Comment 18 Gal Amado 2018-08-13 16:46:53 UTC
deployed on sealusa18 using IR,

core_puddle=2018-08-07.5

(undercloud) [stack@undercloud-0 ~]$ rpm -aq| grep ceph-ansibl
ceph-ansible-3.1.0-0.1.rc10.el7cp.noarch

resaut as expected on controller: 

Last login: Thu Aug  9 18:19:19 2018 from 192.168.24.1
[heat-admin@controller-0 ~]$ ceph osd dump | grep pool
pool 1 'images' replicated size 3 min_size 2 crush_rule 0 object_hash rjenkins pg_num 32 pgp_num 32 last_change 13 flags hashpspool stripe_width 0 expected_num_objects 1 application rbd
pool 2 'metrics' replicated size 3 min_size 2 crush_rule 0 object_hash rjenkins pg_num 32 pgp_num 32 last_change 14 flags hashpspool stripe_width 0 expected_num_objects 1 application openstack_gnocchi
pool 3 'backups' replicated size 3 min_size 2 crush_rule 0 object_hash rjenkins pg_num 32 pgp_num 32 last_change 15 flags hashpspool stripe_width 0 expected_num_objects 1 application rbd
pool 4 'vms' replicated size 3 min_size 2 crush_rule 0 object_hash rjenkins pg_num 32 pgp_num 32 last_change 16 flags hashpspool stripe_width 0 expected_num_objects 1 application rbd
pool 5 'volumes' replicated size 3 min_size 2 crush_rule 0 object_hash rjenkins pg_num 32 pgp_num 32 last_change 17 flags hashpspool stripe_width 0 expected_num_objects 1 application rbd

Comment 19 Joanne O'Flynn 2018-08-15 07:56:49 UTC
This bug is marked for inclusion in the errata but does not currently contain draft documentation text. To ensure the timely release of this advisory please provide draft documentation text for this bug as soon as possible.

If you do not think this bug requires errata documentation, set the requires_doc_text flag to "-".


To add draft documentation text:

* Select the documentation type from the "Doc Type" drop down field.

* A template will be provided in the "Doc Text" field based on the "Doc Type" value selected. Enter draft text in the "Doc Text" field.

Comment 21 errata-xmlrpc 2018-08-29 16:36:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2574

Comment 22 Giulio Fidente 2019-01-24 07:53:34 UTC
*** Bug 1626647 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.