Bug 158385 - Unrecoverable Error when booting under Virtual PC on Mac
Unrecoverable Error when booting under Virtual PC on Mac
Status: CLOSED DUPLICATE of bug 136018
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-21 07:35 EDT by Paul King
Modified: 2015-01-04 17:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-22 00:53:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul King 2005-05-21 07:35:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040825 Camino/0.8.1

Description of problem:
Whilst I reported this as an FC2 bug and was told to test with FC3, the problem persists.  And whilst, I've seen workarounds on this site for PCs, they don't work on Macs.  I have seen mention that one would 'have to recompile the kernal somehow' but that is hardly useful to someone who doen't have any kind of in-depth knowledge, but can follow instructions.

Nothing I have read on this site gives me any comfort that the next release will resolve this but I did read on another site that somone got it to work - though I had problems as I couldn't find the build.

Basically, the suggestion was to locate the build (in /usr/src/linux*) and run 'make menuconfig'.  Changing the processor type to Pentium-MMX seemed to resolve the problem - one having to 'make' and then 'make modules_install install' to complete the process.

My problem?  Could find  any /usr/src/linux* directory, though found /usr/src/redhat.  However, the BUILD, SPECS and all other directories seemed empty.  Can anyone provide a solution to this?

Thanks

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install Fedora Core 3
2.  Attempt to boot
.
  

Actual Results:  Unrecoverable processor error.
Reboots but loop with same problem

Expected Results:  Fedora should have loaded

Additional info:
Comment 1 Sitsofe Wheeler 2005-05-21 17:00:38 EDT
This is probably a dup of the other Virtual PC can't handle 4G/4G bugs - see bug
#136018 and take a look at the bugs marked as dups of it for some hints if you
REALLY want to work around it.

Technically this is a "bug" in Virtual PC but take heart! The 4G/4G patches were
dropped after Fedora Core 3's release so in theory FC4 won't have this problem.
I am always baffled by people running Virtual PC to run Linux on a Mac though.
What can you do in Fedora that you can't already do on OS X already eh?

(BTW: You are technically asking a support question ("how do I recompile and
install a kernel?") rather than a filing a single bug report. You are far better
off asking stuff like this in the forums - http://fedoraforum.org/ )
Comment 2 Dave Jones 2005-05-22 00:53:00 EDT

*** This bug has been marked as a duplicate of 136018 ***

Note You need to log in before you can comment on or make changes to this bug.