Bug 158410 - Failure to recognise Broadcom NetXtreme NIC
Failure to recognise Broadcom NetXtreme NIC
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-21 21:25 EDT by Sean Bruno
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-26 21:05:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lspci -vv on ASUS K8N-DL, dual 246, 6gb ram (18.94 KB, text/plain)
2005-05-24 12:40 EDT, Sean Bruno
no flags Details

  None (edit)
Description Sean Bruno 2005-05-21 21:25:58 EDT
Description of problem:
I am unable to install the x86_64 version of FC4T3 on my machine.  I am not sure
what information you need to begin looking into the issue, but I can install the
i386 version on my machine.

With the i386 version, I can run the uni-processor kernel from FC4T3, but even
with a fully rawhide-updated machine, I cannot run the smp version of the kernel.

Version-Release number of selected component (if applicable):
Test 3

How reproducible:
Every time

Steps to Reproduce:
1.  Attempt to install FC4 T3 on an ASUS K8N-DL based dual-opteron machine.


  
Actual results:
Install proceeds normally, but hangs when trying to "format drives."  It may be
having an issue with the Silicon Image SiI 3114 that I am using for the hard drives.

Expected results:
Install should be successful.

Additional info:
Output of lspci:
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio
Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev a2)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
00:19.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:19.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:19.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:19.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:08.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000
Controller (PHY/Link)
01:09.0 RAID bus controller: Silicon Image, Inc. SiI 3114 [SATALink/SATARaid]
Serial ATA Controller (rev 02)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit
Ethernet PCI Express (rev 11)
04:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 6200
TurboCache] (rev a1)

In addition, I have deactivated the on-board USB controller(Nvidia) and the
primary on-board SATA controller(Nvidia).
Comment 1 Warren Togami 2005-05-21 23:26:15 EDT
When you install 32bit FC4, UP kernel works, but SMP kernel gets stuck during
bootup?
http://people.redhat.com/wtogami/temp/kernel-smp-2.6.11-1.1267_FC4.i686.rpm
Please test if it gets stuck during bootup with this older SMP kernel and report
back.  You may need to install it manually with rpm --oldpackage --nodeps.

The x86_64 issue you mention is probably a different bug than the 32bit SMP
problem.  I'm seeing the 32bit SMP problem too on my dual opteron.  Haven't
tested x86_64 yet.
Comment 2 Warren Togami 2005-05-21 23:44:45 EDT
Bug #158413 is the 32bit SMP kernel unable to boot, while UP kernel does.
Comment 3 Sean Bruno 2005-05-22 12:33:20 EDT
Thanks for the information, I have updated Bug #158413 with my test info on the
kernel that you posted.

I was able to boot that SMP kernel, but the ethernet(Broadcom) seems to be
having issues.

Please email me if you folks want to get into my machine and poke around. 
Nothing sensitive on it as I just built the box.
Comment 4 Sean Bruno 2005-05-24 12:40:18 EDT
The boot.iso (x86_64) from today's rawhide still fails to use the Broadcom
adapter on my machine correctly.  I have attached the output of lspci -vv to
this ticket.  Does it seem that it should work?
Comment 5 Sean Bruno 2005-05-24 12:40:53 EDT
Created attachment 114784 [details]
Output of lspci -vv on ASUS K8N-DL, dual 246, 6gb ram
Comment 6 Sean Bruno 2005-05-25 11:19:34 EDT
I was able to install Fedora directly from Rawhide last night.  I disabled the
Broadcom NetXtreme Ethernet adapter and installed an Intel 10/100 pro to get
past the first set of problems I was having.  

I currently am seeing a "garbled" screen when firstboot starts.  It doesn't
appear that I can interact with the screen in anyway.  This is a PCI-E based
video card(Nvidia 6200 from Asus).  I can't seem to move any further along once
the screen goes into this "garbled" state.

Any ideas?
Comment 7 Sean Bruno 2005-05-25 11:32:04 EDT
The following errors appear just as the kernel starts(post grub but before "Nash
starting"

PCI:  Cannot allocate region 9 of device 0000:00:0e.0
PCI:  Cannot allocate region 3 of device 0000:04:00.0
Failed to allocate mem resource 1000000@fe0000000 for 0000:04:00.0

According to the lspci from the attachment in Comment #5, the first error is
from the nVidia Corporation CK804 PCIE Bridge.

The second error is from nVidia Corporation NV44 [GeForce 6200 TurboCache] which
would explain the mem resource error and the garbled screen.  

These errors do no manifest themselves in the i386 version.
Comment 8 Dave Jones 2005-05-26 20:23:29 EDT
The garbled screen could be an xorg bug. As you've mentioned a number of
different problems in this bug (SATA, Ethernet, and now the garbled display), I
can't reassign this as an X bug, so I recommend opening a separate bug for that.

The hang with the SATA drive you mentioned as the first entry in this bug sounds
like its now fixed, leaving just your failing Broadcom card, correct ?

Please file seperate bugs for multiple issues in future, it makes the
bug-history very difficult to read at times when the subject jumps back and
forth between different issues.
Comment 9 Sean Bruno 2005-05-26 21:05:33 EDT
No problem.  

At this point it would be better to track the Broadcom stuff off of Bug #158468.
 This is one of three tickets that I have filed in regards to my new MoBo.

Since this ticket is basically a "stream-of-conciousness" type of rambling on my
part, I am closing it in order to simplify my issues.

Note You need to log in before you can comment on or make changes to this bug.