Bug 1584123 - In a CNS setup, heketi-cli info on a block-hosting volume displays "Free Size" greater than its actual size
Summary: In a CNS setup, heketi-cli info on a block-hosting volume displays "Free Size...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: cns-3.10
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: CNS 3.10
Assignee: Raghavendra Talur
QA Contact: Neha Berry
URL:
Whiteboard:
: 1600965 1621884 (view as bug list)
Depends On:
Blocks: 1568862 1600965
TreeView+ depends on / blocked
 
Reported: 2018-05-30 10:51 UTC by Neha Berry
Modified: 2018-10-29 08:45 UTC (History)
15 users (show)

Fixed In Version: heketi-7.0.0-2.el7rhgs
Doc Type: Bug Fix
Doc Text:
Previously, If creating block volumes failed Heketi incorrectly added the size of the block volume to the free space counter of the block hosting volume even if the space had not been deducted. Failure to create a block hosting volume would lead to incorrect free space values. With this fix, the free space accounting in Heketi is corrected and Heketi no longer generates incorrect free space values.
Clone Of:
Environment:
Last Closed: 2018-09-12 09:22:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
heketi logs from upgraded setup (171.51 KB, text/plain)
2018-08-02 11:19 UTC, Neha Berry
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2686 0 None None None 2018-09-12 09:23:23 UTC

Comment 15 Neha Berry 2018-08-02 11:19:35 UTC
Created attachment 1472656 [details]
heketi logs from upgraded setup

Comment 20 Anjana KD 2018-08-30 23:32:50 UTC
Updated doc text in the Doc Text field. Please review for technical accuracy.

Comment 22 Anton Mark 2018-09-10 19:10:46 UTC
*** Bug 1621884 has been marked as a duplicate of this bug. ***

Comment 24 errata-xmlrpc 2018-09-12 09:22:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2686

Comment 26 Bipin Kunal 2018-09-14 08:18:41 UTC
*** Bug 1600965 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.