Bug 1584191 - Heketi topology info shows incorrect used space (not zero for devices which had no bricks)
Summary: Heketi topology info shows incorrect used space (not zero for devices which h...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: cns-3.10
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: CNS 3.10
Assignee: Raghavendra Talur
QA Contact: Rachael
URL:
Whiteboard:
: 1598685 (view as bug list)
Depends On:
Blocks: 1568862
TreeView+ depends on / blocked
 
Reported: 2018-05-30 12:58 UTC by Rachael
Modified: 2019-02-11 10:10 UTC (History)
12 users (show)

Fixed In Version: rhgs-volmanager-container-3.4.0-3
Doc Type: Bug Fix
Doc Text:
Previously, if volume create operation failed, space allocated on the device for the bricks was not released in heketi database during clean up operation. With this fix, space allocated for the bricks is released.
Clone Of:
Environment:
Last Closed: 2018-09-12 09:22:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2686 0 None None None 2018-09-12 09:23:23 UTC

Comment 8 Rachael 2018-06-14 05:04:52 UTC
The analysis from the db dump makes sense, but that does not explain why the topology info displays used space on the device with no bricks at all (see the initial description of the bug). So, I am reopening the bug.

Also it would be good if the bugs are not closed without QE consent.

Comment 21 Raghavendra Talur 2018-08-03 11:27:36 UTC
*** Bug 1598685 has been marked as a duplicate of this bug. ***

Comment 26 Anjana KD 2018-08-30 23:34:37 UTC
Updated doc text in the Doc Text field. Please review for technical accuracy.

Comment 27 John Mulligan 2018-09-07 17:34:36 UTC
Doc Text seems OK

Comment 29 errata-xmlrpc 2018-09-12 09:22:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2686


Note You need to log in before you can comment on or make changes to this bug.