Bug 1585369 - Firefox-wayland.desktop fails to group/manage windows
Summary: Firefox-wayland.desktop fails to group/manage windows
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1585492 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-02 04:33 UTC by Chris Irwin
Modified: 2018-06-22 08:08 UTC (History)
12 users (show)

Fixed In Version: firefox-60.0.2-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-22 08:08:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Chris Irwin 2018-06-02 04:33:08 UTC
Description of problem:

The firefox-wayland.desktop file doesn't have browser windows grouped under it. They instead show up under the firefox.desktop file.

Both desktop files are incapable of launching additional windows.

Version-Release number of selected component (if applicable):

firefox-60.0.1-5.fc28.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. Run "Firefox on Wayland" (firefox-wayland.desktop)
2. Observe windows actually grouped under "Firefox" shortcut (firefox.desktop)
3. Middle Clicking "Firefox" and "Firefox on Wayland" present an error, instead of opening additional windows

Actual results:

Error message about the firefox profile being in use

Expected results:

A new browser window is opened

Additional info:

This can be solved by adding a --name parameter to each Exec line in firefox-wayland.desktop, to match the .desktop file name. For example:

Exec=firefox-wayland --name firefox-wayland %u

Comment 1 Martin Stransky 2018-06-04 11:59:04 UTC
*** Bug 1585492 has been marked as a duplicate of this bug. ***

Comment 2 Martin Stransky 2018-06-22 08:08:12 UTC
Fixed by firefox-60.0.2-1.fc28


Note You need to log in before you can comment on or make changes to this bug.